a/c question - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-21-2009
Member
Thread Starter
 
Join Date: Jul 2007
Location: Tamarac, Florida
Posts: 22
a/c question

hey everyone,

im pretty sure that this question has been answered, but i've been pouring through a bunch of threads using search and i couldnt find an answer to my problem

so my a/c blows cold but most of the time when i rev to higher rpms the a/c switches from the cabin vents to the defog vent up next to the windshield. im guessing like a relay problem or something, but im not to sure what it could be.

any advice would just be awesome

thanks in advance
Reply With Quote
  #2  
Old 06-21-2009
quicksilver2001's Avatar
Member
 
Join Date: Dec 2004
Location: Opelousas, Louisiana
Posts: 704
sounds like a vacuum leak. check your vacuum hoses under the hood for cracks/broken.
Reply With Quote
  #3  
Old 06-21-2009
Member
Thread Starter
 
Join Date: Jul 2007
Location: Tamarac, Florida
Posts: 22
Quote:
Originally Posted by quicksilver2001 View Post
sounds like a vacuum leak. check your vacuum hoses under the hood for cracks/broken.
heading out to do that right now, do you know which hoses in particular i should check?
Reply With Quote
  #4  
Old 06-21-2009
FireRanger's Avatar  
Join Date: May 2004
Location: CT
Posts: 0
The doors that control air flow are use vac pressure to hold them in place. When vac pressure is lost, a spring returns the door to the home default position which is defrost only. There is naturally less vac pressure at high RPM but I don't think it should be dropping that low which says to me there is a leak somewhere.
Reply With Quote
  #5  
Old 06-21-2009
Member
Thread Starter
 
Join Date: Jul 2007
Location: Tamarac, Florida
Posts: 22
i was checking under my hood and i saw this broken hose, could this be the one causing my problem?

Name:  IMG_5038.jpg
Views: 0
Size:  75.6 KB

Name:  IMG_5036.jpg
Views: 0
Size:  89.2 KB
Reply With Quote
  #6  
Old 07-06-2009
Member
Thread Starter
 
Join Date: Jul 2007
Location: Tamarac, Florida
Posts: 22
if anyone can tell me what that broken hose goes to, then let me know.
thanks in advance
Reply With Quote
  #7  
Old 07-06-2009
FireRanger's Avatar  
Join Date: May 2004
Location: CT
Posts: 0
I think that is just the water drain from the outside air intake plenum in front of the windshield. Probably nothing to do with it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
04-05 Valence Question. Also lift question. Masteratarms93 General Ford Ranger Discussion 4 04-29-2010 02:18 PM
NOT a Ranger Light Question, but still a Ford Light Question buggman General Technical & Electrical 1 11-19-2008 12:00 PM
Superlift question and RCD question ranger_1999 General Ford Ranger Discussion 22 11-05-2008 09:31 AM
Question about my DD (focus question) CJGSAY 2.3L & 2.5L I4 Tech 2 06-08-2008 11:52 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:42 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.