HELP..or she goes.. - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 02-16-2007
Member
 
Join Date: Nov 2005
Location: Avon, IN
Posts: 756
Quote:
Originally Posted by coolpeoplswillis
speed sensor?
not even close...
Reply With Quote
  #27  
Old 02-16-2007
l2en's Avatar
Member
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
Quote:
Originally Posted by Big04Ranger
not even close...
distributor belt?
Reply With Quote
  #28  
Old 02-17-2007
Member
Thread Starter
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
lmao if only !!

SOO i brought my truck into the shop..first off all rangers are gay to lift on a 4 arm hoist lol second of all i found a few things..rear shocks finally gave out and are leaking got new ones ordered for tuesday..front drivers side caliper is leaking from somthing ill fix it tuesday with the shocks and everything else was perfecto!

i hooked it up to out computer..sorry it wasnt 9000$ its 20 000$ LOL i was told if i dropped it....i wont even tell you what i was told haha..ran some test passed everything started her up let it get all the information on the computer and watched it diag everything..she idles at 750-800 rppm when warm i found out and the rev limiter kicks in at 3100 rpm in idle mode..but NO codes for my damn problem..nothing stored nothing at all..so i cleaned my MAF had the mechanic beside me..alls he worke don was ford before and he went through it said it was in decent shape for what hes seen and delt with a few things he told me to watch then he hinted at the tranny which is gay..so i guess we'll see where this goes..im puttin a new filter in the tranny tuesday too and given it a good flush..dunno what else i can do..

there really trying to push a 07 tacoma 6 speed on me lol
Reply With Quote
  #29  
Old 02-17-2007
D.
Unregistered User
 
Posts: n/a
Quote:
Originally Posted by Sonic_03
if its tranny related..shes gone tomorrow...i work for toyo ill have them bring me in a used tacoma and get a good deal on it..i dont want the headache lol
From the sounds of the way your throwing the ' I work at toyota ' theme around, its what you want to do anyway.

*IF* its anything like a ' rev limiter ', it would more then likely be something ECC/ECM related. Either timing or as Zach stated, the stall converter locking out. Just because theres no ' codes ' being thrown, it doesn't rule out the ECM as a whole to begin with.

Theres a reason I spent 3 grand on an EM Tec3.

Last edited by D.; 02-17-2007 at 09:23 PM.
Reply With Quote
  #30  
Old 02-17-2007
Member
Thread Starter
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
yea the like 160 000 km bumper to bumper warranty sounds good to me LOL there doing a search for me looking for a few things..as for now the rangers life depends on how it acts up within the next few weeks..im gonna print out a diag sheet off our computer at work there was 3 codes thrown i totally forgot about and i have NO idea what they are..just a whole lot of numbers its said everything passed its test except these 3 things i think its enviro..ill have to get a print out on monday..
Reply With Quote
  #31  
Old 02-18-2007
SHOman86's Avatar
Member
 
Join Date: Sep 2005
Location: Lakeland, Fl
Posts: 2,469
u checked ur blinker fluid...that might have a problem with it
Reply With Quote
  #32  
Old 02-18-2007
Member
 
Join Date: Mar 2006
Location: Barrie,Ontario Canada
Posts: 137
I had similar problems with my old 99 Z-24 Cavalier ... turns out it was a shattered catalytic coverter and it was cloggin the exaust. if I accelerated very slowly it would be fine but if i hit the pedal anything faster then a snails pace the car would stutter/shake/sputter/die.
Reply With Quote
  #33  
Old 02-18-2007
NastyNate's Avatar
Member
 
Join Date: Oct 2006
Location: Vacaville, CA
Posts: 92
You could have a compression problem. If that is the case i think you have to replace the motor or get a total rebuild.
Reply With Quote
  #34  
Old 02-19-2007
rangerb's Avatar
Member
 
Join Date: Aug 2006
Location: PA
Posts: 100
try unplugging the Torque Converter Clutch Solenoid and drive it around and see if it still does it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Well she's in the shop Nate97Ranger Drivetrain Tech 14 03-10-2007 07:41 AM
"Captain, I'm givin her all she's got!" Hefavitzen General Ford Ranger Discussion 25 06-11-2006 02:48 PM
She's Mine!!! Gearhead61 General Ford Ranger Discussion 55 12-06-2005 12:20 PM
She's in the shop... W1CKY General Ford Ranger Discussion 1 06-14-2004 03:01 PM
She's acting up... RuggerNate General Technical & Electrical 13 06-09-2004 09:25 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:55 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.