hey guys!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-05-2008
ranger_banger's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: cedar falls, iowa
Posts: 405
hey guys!!!

well, my Ranger's been sitting for about 11 months now and the damn thing wont turn over anymore. i bought an Optima Red Top battery about a week ago with 720 CCA, so that's plenty to get it moving, but i hooked it up, and when i turn the key, all it does is just click once. So am i looking at a new starter or do you think the engine seized since it's been sitting for so long, or maybe, just maybe, since it's approximately 15 degree's that it's just froze up?

oh, and i bought those 'projector' headlights off ebay last night, so i'll finally have something new for the truck!
Reply With Quote
  #2  
Old 01-05-2008
thesoundmaster's Avatar
Member
 
Join Date: Mar 2007
Location: Centennial CO
Posts: 5
Quote:
Originally Posted by ranger_banger
well, my Ranger's been sitting for about 11 months now and the damn thing wont turn over anymore. i bought an Optima Red Top battery about a week ago with 720 CCA, so that's plenty to get it moving, but i hooked it up, and when i turn the key, all it does is just click once. So am i looking at a new starter or do you think the engine seized since it's been sitting for so long, or maybe, just maybe, since it's approximately 15 degree's that it's just froze up?

oh, and i bought those 'projector' headlights off ebay last night, so i'll finally have something new for the truck!
Mine's been sitting for 2 months and it's doing the same. However, mine makes rapid clicking like a relay snapping once my key hits the off position and continues for quite a while.
Reply With Quote
  #3  
Old 01-05-2008
bpolly_2004's Avatar
Member
 
Join Date: Mar 2007
Location: Huntsville mo
Posts: 559
i think its the cold.
Reply With Quote
  #4  
Old 01-11-2008
ranger_banger's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: cedar falls, iowa
Posts: 405
you think its just the starter?
Reply With Quote
  #5  
Old 01-11-2008
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Pull the Rad cap and see if the coolants frozen. Then put a socket and ratchet/breaker bar on the crank pulley bolt and try turning by hand. If it turns, then your probably looking at a starter or related electrical problem.
Reply With Quote
  #6  
Old 01-11-2008
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
Are the battery cables hooked up good? Usually if it just clicks one, it's a connection being broke. Check the connections.
Reply With Quote
  #7  
Old 01-13-2008
94greenmachine's Avatar
Member
 
Join Date: Aug 2006
Location: Virginia Beach, VA
Posts: 553
Ok, I had the same thing on my 94 4 banger. The Negative cable from the battery to the Block (connects under the power steering pump on the block itself) had old copper in it and was causing the cable to arc inside the jacket and destroy the copper strands. I bought a new gound cable and connected it to one of the mounting stud bolts for the A/C compressor and she started over PERFECTLY! Check that first, it is cheaper and ALOT easier!
Reply With Quote
  #8  
Old 01-14-2008
ranger_banger's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: cedar falls, iowa
Posts: 405
Ok, thanks for the suggestions guys. Its like 10 degrees out, and its not supposed to warm up for a good week, so once it does, i'll check all the battery cables, and try moving the crank with a breaker bar. my headlights came today too, so i'm pretty anxious about getting those in. Thanx again guys
Reply With Quote
  #9  
Old 01-14-2008
07Ranger's Avatar
Member
 
Join Date: Mar 2007
Location: lima/dublin, ohio
Posts: 1,267
if u leave a truck for a while your trucks fuel octane will be ****ing LOW. go get the highest octane fuel in your area and mix it with fuel addictives. then add that mixture to your gas tank, they will blend to make a 87-95ish octane.

1 week a truck sits: the octane of the fuel goes down by 1!

EDIT: 11 MONTHS? please drain the fuel and add fresh
Reply With Quote
  #10  
Old 01-14-2008
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
Well, the fuel won't solve the click problem, lol -- but you should add a gas preservative if you're going to let it sit for sure.

Another common problem is oxidation INSIDE the cable ends. Where the cable is crimped or clamped to the actual ring which goes onto the battery terminals.

Did you clean the inside of the battery terminal rings before you put them on the new battery? Believe it or not, that can also be a problem. When a uniform layer of oxide forms on the inside it acts like a semi-conductor or resistor and you get little current to any load.

To checl for this if you have a test light or meter, touch them to the battery post tops themselves while someone tries to crank the vehicle. If the voltage drops big time, you have a dead battery or an overload condition (like a bad starter or seized engine).

If the voltage stays up on the battery, make a hole in the cable insulation a little way down both the positive and negative cables and test there as someone tries to crank it.

If the voltage drops a lot, you have a connection problem at the battery. If the voltage stays up, your problem is the starter, the solenoid, or the connection at the starter, etc.
Reply With Quote
  #11  
Old 01-15-2008
07Ranger's Avatar
Member
 
Join Date: Mar 2007
Location: lima/dublin, ohio
Posts: 1,267
i didnt read the whole thing i just saw the fact u were trying to start it after 11 months. just hate to see people try to start cars after a year of sitting and drive around like there engine is the same as when they shut it off.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Hey HEy dangerranger69 Member Introductions 22 01-05-2009 05:34 AM
Hey Hey Hey from Sin City Cheeky Member Introductions 23 09-24-2008 02:08 AM
Hey hey. Gregger Member Introductions 10 06-30-2008 09:03 PM
hey hey 4x4sport08 Member Introductions 18 11-27-2007 01:47 PM
Hey Hey Hey Skyjacker_44 General Ford Ranger Discussion 29 01-16-2006 12:30 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:52 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.