Horn frozen or waterlogged - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-06-2005
Member
Thread Starter
 
Join Date: Nov 2004
Location:
Posts: 3,115
Horn frozen or waterlogged

I did some searching but didn't have a definity fix. I know other people have had this problem. My horn sounds like a horn off a cheap british car. I don't know what happended. I was in wharton on Dec 1st but it was fine until yesterday, I don't think it has gotten any colder since the first.
Reply With Quote
  #2  
Old 12-06-2005
Mr. Special's Avatar
Member
 
Join Date: May 2005
Location: Irvine, CA
Posts: 3,411
mm what happened to me before. After i was off-roading and cleaned my truck. I tired taking the horns off and getting the water out of them and using a hair dryer to dry them out... with no sucess. I dont know if your truck is still under warrenty.. but it is a covered item so i just ended up taking it to the Dealership and having them give me two new horns.
Reply With Quote
  #3  
Old 12-06-2005
rngprerunner's Avatar
Member
 
Join Date: Jun 2004
Location: Long Beach CA
Posts: 3,453
Autozone.. 13bucks.. nice loud replacement.. for the price when mine went it wasn't worth the hastle of trying to fix it.. time is money..
Reply With Quote
  #4  
Old 12-06-2005
Mr. Special's Avatar
Member
 
Join Date: May 2005
Location: Irvine, CA
Posts: 3,411
Quote:
Originally Posted by rngprerunner
Autozone.. 13bucks.. nice loud replacement.. for the price when mine went it wasn't worth the hastle of trying to fix it.. time is money..
cool thx Jason. That shall come in handy once my warrenty runs out [hah i've already been through 2 sets of horns (4 in all)]
Reply With Quote
  #5  
Old 12-06-2005
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
take it out and wire in a semi horn problem solved
Reply With Quote
  #6  
Old 12-06-2005
rngprerunner's Avatar
Member
 
Join Date: Jun 2004
Location: Long Beach CA
Posts: 3,453
Quote:
Originally Posted by Mr. Special
cool thx Jason. That shall come in handy once my warrenty runs out [hah i've already been through 2 sets of horns (4 in all)]
haha.. nice

I'v only killed one, which is supprising since it sits out in the open now and I'v been through some pretty deep water crossings..
Reply With Quote
  #7  
Old 12-06-2005
Mr. Special's Avatar
Member
 
Join Date: May 2005
Location: Irvine, CA
Posts: 3,411
lol yea i blame our RF meets. Killed one set after el mirrage when i was cleaning the truck and the second set obvously died at Stoddard when i decided to attack that lake one too many times lol but ofcourse all ford needs to know is that they somehow just went out
Reply With Quote
  #8  
Old 12-06-2005
Member
Thread Starter
 
Join Date: Nov 2004
Location:
Posts: 3,115
yeah i still have warrentee so I will get it done then
Reply With Quote
  #9  
Old 12-06-2005
ranger024x4's Avatar
RF Veteran
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
ive killed 4 so far...


my solution... an import horn.... theres no way water can sit up there...


but it does sound reall ghey lol
Reply With Quote
  #10  
Old 12-06-2005
GrafixGuy's Avatar
RF Veteran
iTrader: (3)
 
Join Date: Jan 2005
Location: Montgomery, AL
Posts: 8,703
if its cold mine has a higher tone :(. I'll look at autozone :)
Reply With Quote
  #11  
Old 12-06-2005
Alon's Avatar
Member
iTrader: (13)
 
Join Date: Jun 2004
Location: Long Beach, CA
Posts: 2,555
mine died cause it was filled with mud, then i got a 3 tone airhorn kit and it sounded pretty good. i mounted it under the truck because i wasnt planning on going in any mud..... well that changed and now only one of the horns works and it sounds like crap, hopefully i can clean it up.

if you do get a replacement make sure you mount it so that no mud can get in next time
Reply With Quote
  #12  
Old 12-06-2005
Member
Thread Starter
 
Join Date: Nov 2004
Location:
Posts: 3,115
out of all the mudding i have done in the last year I can't help but think why now ? I did notice my drivers side gap guard was loose maybe it let more mud/water in to the horn maybe ?
Reply With Quote
  #13  
Old 12-19-2005
GrafixGuy's Avatar
RF Veteran
iTrader: (3)
 
Join Date: Jan 2005
Location: Montgomery, AL
Posts: 8,703
anyone have a pic of the horn kit at A-Z?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Frozen/Seized Rear Drum Brake Ranger 2000 rickyrockrat General Technical & Electrical 3 12-30-2012 12:55 PM
E-Brake stuck/frozen, mushy brake pedal rideac1 General Technical & Electrical 30 01-19-2009 11:56 AM
Frozen clutch? rizoss16 General Ford Ranger Discussion 35 01-12-2009 01:34 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:57 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.