I might have made a mistake - Page 3 - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #51  
Old 12-11-2009
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Quote:
Originally Posted by Rolldogg View Post
Sorry, I can't help it. You ***** about your truck in almost EVERY thread in here. Here's a cookie though.
Looks like you are doing the same with my posts. Cookie rejected.
Reply With Quote
  #52  
Old 12-11-2009
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Quote:
Originally Posted by brianjwilson View Post
Bunch of sissies complaining about manual transmissions! Even my wife doesn't complain about a manual transmission in traffic! haha
X2!!!
Reply With Quote
  #53  
Old 12-11-2009
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Quote:
Originally Posted by whippersnapper02 View Post
Looks like you are doing the same with my posts. Cookie rejected.
I don't feel like playing the "tit for tat" game with you tonight.
Reply With Quote
  #54  
Old 12-11-2009
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Quote:
Originally Posted by Rolldogg View Post
I don't feel like playing the "tit for tat" game with you tonight.
Ok. Well I'm here if you change your mind.
Reply With Quote
  #55  
Old 12-11-2009
Sixt9coug's Avatar
Member
iTrader: (7)
 
Join Date: May 2006
Location: Norwalk, CA
Posts: 1,034
Quote:
Originally Posted by whippersnapper02 View Post
Have any idea? Anyone? Again I'm not the only one with this problem. The slave is known to be crap. I'm just the only one that complains. Its my fault for not researching this vehicle before I bought it. Also to me its not worth trying to figure out the problem. You can't do anything with the truck anyway. Can't tow. Can't put people in it. I have had 2 other manual vehicles before and I never had a problem with the transmission. Each time that the clutch was done a different mechanic has worked on it. The only thing I haven't replaced is the clutch line. But I doubt that will help any. This last time I used stock replacement parts and the same crap happened sooner. Not even a year and it is failing again. I'm tired of dealing with it. It shouldn't happen. I won't just deal with it either. Truck breaks and I don't work. No work then I don't get paid.


Has the same mechanic ever worked on it twice? Perhaps if the same one has, they would know that its odd that the same part would fail so soon after just being installed and they might investigate further. Sometimes having a single person work on it can bring familiarity with the vehicle and make diagnostics easier. As far as the hose being bad you never know if it could be the problem. I had a brake hose fail on an old Cougar of mine. Looked fine all over except that it failed internally. Hey its a thought.

My 04 had a manual trans and i never had a problem with the trans or clutch. Granted, i only had 60K miles on it but still. The only thing that went bad on it was a starter and a tie rod end.

As far as not being able to put people in it, well, you can only get two people in an RX7 and it doesnt tow crap either. If that was enough of a concern perhaps you just did not buy the right vehicle for your personal needs.
Reply With Quote
  #56  
Old 12-11-2009
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Quote:
Originally Posted by Sixt9coug View Post
Has the same mechanic ever worked on it twice? Perhaps if the same one has, they would know that its odd that the same part would fail so soon after just being installed and they might investigate further. Sometimes having a single person work on it can bring familiarity with the vehicle and make diagnostics easier. As far as the hose being bad you never know if it could be the problem. I had a brake hose fail on an old Cougar of mine. Looked fine all over except that it failed internally. Hey its a thought.

My 04 had a manual trans and i never had a problem with the trans or clutch. Granted, i only had 60K miles on it but still. The only thing that went bad on it was a starter and a tie rod end.

As far as not being able to put people in it, well, you can only get two people in an RX7 and it doesnt tow crap either. If that was enough of a concern perhaps you just did not buy the right vehicle for your personal needs.
I have used different people because I though maybe they did something wrong. Even with Ford did it I had to replace it after a year.

I don't own the RX7 anymore. Back then all I cared about was speed. The only reason I bought this truck was because it was cheap and I didn't make much at the time. I make good money now but I'm saving to have a decent down payment. I even bought a quad so I can stop wheeling my truck because I thought that was the problem. Nope. I was happy for some time but then the clutch problems started.
Reply With Quote
  #57  
Old 12-11-2009
Sixt9coug's Avatar
Member
iTrader: (7)
 
Join Date: May 2006
Location: Norwalk, CA
Posts: 1,034
Quote:
Originally Posted by whippersnapper02 View Post
I have used different people because I though maybe they did something wrong. Even with Ford did it I had to replace it after a year.

I don't own the RX7 anymore. Back then all I cared about was speed. The only reason I bought this truck was because it was cheap and I didn't make much at the time. I make good money now but I'm saving to have a decent down payment. I even bought a quad so I can stop wheeling my truck because I thought that was the problem. Nope. I was happy for some time but then the clutch problems started.


If you had a car that blew a head gasket at the #3 cylinder and you had it repaired but it kept happening over and over again at the same cylinder would you suspect that its a crappy head gasket or would you think that there is possibly something else wrong? If you keep going to different people the original mechanic probably thinks even to this day that the repair was fine and flawless. If you had brought it back it would have given him time to research further into the problem.

I know others have had the problem as well, but have any had the problem as many times as you have? That leads me to believe there is something else going on that has not been diagnosed.

Has the trans ever been replaced (to your knowledge)? Has a repair history report ever been pulled up on it? (a Ford dealer would have that handy of all the work thats been done with them).
Reply With Quote
  #58  
Old 12-11-2009
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Quote:
Originally Posted by Sixt9coug View Post
If you had a car that blew a head gasket at the #3 cylinder and you had it repaired but it kept happening over and over again at the same cylinder would you suspect that its a crappy head gasket or would you think that there is possibly something else wrong? If you keep going to different people the original mechanic probably thinks even to this day that the repair was fine and flawless. If you had brought it back it would have given him time to research further into the problem.

I know others have had the problem as well, but have any had the problem as many times as you have? That leads me to believe there is something else going on that has not been diagnosed.

Has the trans ever been replaced (to your knowledge)? Has a repair history report ever been pulled up on it? (a Ford dealer would have that handy of all the work thats been done with them).
Well for that reason I changed the master out. No change. I have no idea if the tranny has ever been changed. I don't get the problem diagnosed because what would cause the slave to leak but the breakdown of its materials? Also you would think that if the line was bad it wouldn't even work for 12 months. No problem bleeding and not problem of any kind after the job is done. Drive to work and where ever I need to go and all of a sudden no clutch.
Reply With Quote
  #59  
Old 12-11-2009
fourliter dan's Avatar
Member
 
Join Date: Dec 2007
Location: Lebanon, OR
Posts: 2,229
try and get your old truck back and get a camburg kit... or find what what really want!
Reply With Quote
  #60  
Old 12-11-2009
Ray_Welder's Avatar
Member
 
Join Date: Jan 2008
Location: Zephyrhills, FLorida
Posts: 1,037
is it possible for the slave to overextend and blow the seals out?
Reply With Quote
  #61  
Old 12-11-2009
sniper_101's Avatar
Member
 
Join Date: Jul 2005
Location: Sask, Canada
Posts: 1,902
Quote:
Originally Posted by brianjwilson View Post
Bunch of sissies complaining about manual transmissions! Even my wife doesn't complain about a manual transmission in traffic! haha
x3

Try an 18-spd for 14hrs a day . . .
Reply With Quote
  #62  
Old 12-12-2009
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
Quote:
Originally Posted by Sixt9coug View Post
I've paid for two with my own money and still dont get why you are complaining so much. If you are having the same problem over and over and over again do you think that maybe you or your mechanic arent getting to the root of the problem? Maybe there is something else in the setup that is out of tolerance or something?

It reminds me of dealing with guys at work that complain over and over again if they are having problems with our product. Its never their fault and its always a faulty product. Well, im not blaming you for whats going on with your truck ( I dont think its you causing it) but i do think that maybe the problem lies somewhere else in the system.

Instead of it being automatically a POS because it failed, try to find out WHY it failed.
thank god someone else understands basic problem solving skills! every vehicle i have ever owned has been fully paid for by working my *** off. and believe me there have been some long, ****ty, and painful hours gone into paying for and modifying my vehicles
Reply With Quote
  #63  
Old 12-12-2009
TCP_Ranger's Avatar
Member
 
Join Date: May 2009
Location: Lafayette, Indiana
Posts: 90
if you want a auto we can trade. mines only a alot older but its got less miles :)
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
made a huge mistake, VTranger 4.0L OHV & SOHC V6 Tech 9 08-21-2015 09:13 AM
I think i made a mistake! Ford Fan General Ford Ranger Discussion 1 08-02-2014 02:59 AM
woops i have made a mistake fellas >< 98 2.9L & 3.0L V6 Tech 24 05-03-2010 11:54 AM
so i have the oppurtunity to have a custom roof rack made for the truck Tys 4x4 FTW General Ford Ranger Discussion 22 04-02-2009 11:23 AM
Anyone make this mistake? graniteguy General Technical & Electrical 6 06-15-2007 07:54 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:48 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.