I think I have a tranny problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-23-2009
Tys 4x4 FTW's Avatar
RF Veteran
Thread Starter
iTrader: (8)
 
Join Date: Jul 2008
Location: Las Vegas, Nevada
Posts: 6,575
I think I have a tranny problem

After only 36k miles i think im having a pretty major issue.

I hardly do it, but today i happened to go WOT at about 70 mph. it downshifts and pops into neutral. i let off the gas and let the rpm's go back down and it goes back into gear. idk wtf the deal is. but its not the first time this has happened.

any clue as to what it is and if its a cheap fix or not? warranty is up now.
Reply With Quote
  #2  
Old 10-23-2009
Toms994x4's Avatar
Member
iTrader: (4)
 
Join Date: Jul 2009
Location: Sanford, NC
Posts: 1,300
My buddys 5.4 FX4 F150 does that same damn thing. So does my 4.6 F150. His truck sat at the dealership for 3 weeks while it was being fixed. I didn't ask him if they fixed it or not though.
Reply With Quote
  #3  
Old 10-23-2009
Tys 4x4 FTW's Avatar
RF Veteran
Thread Starter
iTrader: (8)
 
Join Date: Jul 2008
Location: Las Vegas, Nevada
Posts: 6,575
think you could find out for me? its not a HUGE deal because i rarely smash it from that fast since its not a race car. i just hope the problem doesn't get worse. hopefully when i go to trade it in this is a problem they won't find :)
Reply With Quote
  #4  
Old 10-24-2009
annguyen1981's Avatar
Member
iTrader: (4)
 
Join Date: Apr 2009
Location: Chicopee, MA
Posts: 1,888


Sorry... I couldn't resist.

Reply With Quote
  #5  
Old 10-24-2009
Member
 
Join Date: Apr 2007
Location: Kansas
Posts: 311
Quote:
Originally Posted by Tys 4x4 FTW View Post
think you could find out for me? its not a HUGE deal because i rarely smash it from that fast since its not a race car. i just hope the problem doesn't get worse.
Quote:
hopefully when i go to trade it in this is a problem they won't find :)
Note to self ( NEVER ) buy anything from this person!!!!!!!!!!!!!!!!!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
'99 4.0 I think someone swaped my tranny cuz I have these xtra wires (pic) MNBen Drivetrain Tech 0 12-28-2010 05:48 PM
I think I might have a problem ? konacam08 4.0L OHV & SOHC V6 Tech 0 04-26-2008 07:43 PM
I think I have a leaf spring problem (PICS). FlounderFX4 Suspension Tech 23 06-27-2007 07:30 PM
Think i have a problem Noone Ranger-Forums Office 7 12-10-2006 07:29 AM
Think i might have a problem YellowEdge 2.9L & 3.0L V6 Tech 2 08-15-2005 10:36 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:12 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.