idle drops then returns - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-14-2011
Member
Thread Starter
 
Join Date: Oct 2011
Location: blue springs mo
Posts: 21
idle drops then returns

Hi- have a problem on a 4 banger 99 Mazda B 2500. When going to idle off of running on highway or really anytime the idle drops down to almost stalling then after a second goes back up to 500 and then back up to 950. Truck is getting a P0 171 lean code. Not really sure how to tackle this one. Any advice appreciated. Still getting close to 26 mpg though.
jeff
Reply With Quote
  #2  
Old 10-14-2011
zak873's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2010
Location: southcarolina
Posts: 1,108
if I would have to take a guess, I'd say its the idle air control valve. my jeep has the same problem, so I replaced the throttle position sensor, and it didn't fix it. so if I were you, start with the idle air control valve. you can usually take it off and clean it with carb or eletrical cleaner, inside where the plunger is. I'm to cheap to replace my IACV on my jeep, so I deal with it haha.
Reply With Quote
  #3  
Old 10-14-2011
Member
Thread Starter
 
Join Date: Oct 2011
Location: blue springs mo
Posts: 21
well doesnt sound hard to replace.
Reply With Quote
  #4  
Old 10-14-2011
Member
Thread Starter
 
Join Date: Oct 2011
Location: blue springs mo
Posts: 21
also cheap enuf at around 60.00 but what are the chances of me successfully cleaning the current one and having good results?
Reply With Quote
  #5  
Old 10-14-2011
Masteratarms93's Avatar
Member
iTrader: (8)
 
Join Date: Mar 2010
Location: Goose Creek SC
Posts: 4,685
My 2000 2.5L does this as well. Usually idling after I come to a stop. I cleaned my IACV twice and the issue persists. I assume if I replace it the problem will go away but as long as the truck doesn't stall out I'm fine with it.
Reply With Quote
  #6  
Old 10-14-2011
Member
Thread Starter
 
Join Date: Oct 2011
Location: blue springs mo
Posts: 21
well.. maybe cleaning may not work with my mileage at 160XXXX but i will certianly try cleaning and replace if i need.
Reply With Quote
  #7  
Old 10-14-2011
zak873's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2010
Location: southcarolina
Posts: 1,108
Quote:
Originally Posted by jeffhestand View Post
also cheap enuf at around 60.00 but what are the chances of me successfully cleaning the current one and having good results?
its extremely easy to replace. the only way to find out if cleaning the old one will be successful is to try it. I've cleaned mine several times and it still sticks, but like kevin said, as long as it doesnt stall, ohwell. I drive it anyways, and the longer trips I take, the less I notice it.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
97 2.3L only warms up driving, Drops to C at idle JigN SOHC - 2.3L & 2.5L Lima Engines 6 12-27-2013 04:27 PM
Engine lopes at idle, drops volts when defrost on 08EscapeArtist DOHC - 2.3L Duratec / Mazda L Engines 4 02-14-2010 05:05 AM
New battery, then new alternator, then found broken wire... psvines General Technical & Electrical 1 01-01-2010 07:15 PM
Idle drops down sometimes korey89 2.9L & 3.0L V6 Tech 7 07-23-2008 03:30 PM
Accident Mod Part 2: The Accident Returns. (Loooong) W1CKY General Ford Ranger Discussion 6 01-01-2006 11:11 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:24 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.