Need help ASAP!!!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-09-2010
98rangerxlt's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Bakersfield, CA
Posts: 725
Need help ASAP!!!!!

98 Ranger with the 5r55e trans.Installed my amp power wire and disconnected the neg batt cable got it installed now the Sppedo is not working the ABS light is not on and the trans shift ok.So if I can get some help ASAP.Thanks.
Reply With Quote
  #2  
Old 06-09-2010
BettyVo7Ranger's Avatar
Member
iTrader: (3)
 
Join Date: Apr 2008
Location: Niagara Falls, New York
Posts: 695
check fuses
Reply With Quote
  #3  
Old 06-09-2010
Silver's Avatar
Member
 
Join Date: Jun 2006
Location: edenton,nc
Posts: 2,708
yep if i remember correctly its #10 fuse
Reply With Quote
  #4  
Old 06-09-2010
98rangerxlt's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Bakersfield, CA
Posts: 725
More problems

Quote:
Originally Posted by Silver View Post
yep if i remember correctly its #10 fuse
CEL is on,Dome light seatbelt light or dinger, and key dinger, and lights on dinger don't work.Could the GEM fuse be blown or did I knock the GEM out.Thanks for all the help.
Reply With Quote
  #5  
Old 06-09-2010
98rangerxlt's Avatar
Member
Thread Starter
 
Join Date: Mar 2009
Location: Bakersfield, CA
Posts: 725
Got the truck fixed it was #10 fuse and #20 fuse and cleared the light.
Reply With Quote
  #6  
Old 06-09-2010
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
Good to hear you got it figured out. It's a relief when its just fuses
Reply With Quote
  #7  
Old 05-28-2014
Member
 
Join Date: May 2014
Location: smyrna, tn
Posts: 10
Dealing with hesitation, not normally in 1st or 2nd gear, 99% of time in 3rd, 4th and 5th. Began in 4th & 5th after transmission replaced and plugs. Got worse, even after another set of plugs, wires, fuel filter and pump, converter, muffler, two coils, three complete diagnostics eventually averaging 140-180 compression #3 & 4 strongest. Scoping valves for valve bend burn or broken springs or others problems, leak down under 2-10%, fuel flow & pressure tests fine, amf sensor cleaned, but giving computer a high elevation read, fuel mix rich at 2000 rpm's with slight load. Strong in first and second gear. Starts sputtering into 3rd & 4th. Acts like it is flooding out, by creating similar load as slower speed in 1st & 2nd by riding brakes till sputtering begins, and a strong smell of unburned fuel.

Everything else checks out mechanically sound including transmission which is standard 5 speed. 145,000 miles on chassis, no leaks, no blue smoke or oil loss. Well taken care of.

One of three diagnostics showed Timing belt off or stretched by 6% and crank shaft pulley hub maybe 1% or 1/16" play.

Just did a new pulley hub and timing belt, Also put a new egr valve in.

Big question... what next?

...Computer next? Another sensor? Knock sensor? Fuel injectors even with normal fuel flow tests? What else?

Help!
Reply With Quote
  #8  
Old 05-28-2014
Member
 
Join Date: May 2014
Location: smyrna, tn
Posts: 10
1994 2.3 Ford Ranger
Reply With Quote
  #9  
Old 05-28-2014
01RangerEdge's Avatar
Scrambles the DeathDealer
iTrader: (11)
 
Join Date: Jul 2009
Location: Jackson, MO
Posts: 7,598
You should start your own thread, this one is almost 4 years old
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
E-Brake help. Please help me out. Need to get done asap. rybread5520 General Technical & Electrical 2 01-02-2009 10:41 PM
need help asap RANGERLOVER General Ford Ranger Discussion 6 09-25-2008 01:02 PM
need help asap!!! Bad water leak!!! blkranger Interior Semi-Tech 3 07-07-2005 01:53 PM
Need Help Asap BananaEdge Exterior Semi-Tech 14 04-16-2005 08:47 PM
I NEED GAUGE HELP ASAP!! (this is different than my previous gauge post) please! TippnOver Interior Semi-Tech 7 02-02-2005 12:56 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:03 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.