Need Help Badly!!!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-05-2006
04edge's Avatar
Member
Thread Starter
 
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
Need Help Badly!!!!!

My truck is acting up like crazy between 45 and 55 it viberates really bad but only for like 10 secs then it goes away and only does it when i am light on the gas petal. It only does it in overdrive. I have no clue what it is but when i stomp on it no problems at all. I check the tranny fuild it was good, there are no leaks, and its still just as red as when it was put in. At first I thought it was something to do with suspension but when I turn off overdrive no vibration. If I am really light on the gas I can get it to shift in overdrive at 40 and wont vibrate until i hit around 45 to 50. It pisses me off because it worked fine earlier today and just started out of nowhere I just had the trans fixed 5000 miles ago and of course the warranty was only 5000 miles go ****ing figure. Any clues on what it could be?


and o yea it shifts perfectly fine in the rest of the gears and doesnt do it when i slow down either.
Reply With Quote
  #2  
Old 02-05-2006
04edge's Avatar
Member
Thread Starter
 
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
Ok now I am really confused because it will only do it at 60mph under light acceleration. Any ideas? I hate to have to take it to the dealer because I know I will be charged up the butt but I guess I have no choice because I dont know where its coming from.
Reply With Quote
  #3  
Old 02-05-2006
Member
iTrader: (1)
 
Join Date: Mar 2005
Location: Acworth, GA
Posts: 2,099
A basic question to consider, are your tires balanced or have they been balanced recently?

I know I know, it only does it in overdrive, I have unbalanced 38's on beadlocks, and sometimes I can drive the hour drive to school and it will ride smooth as silk, and the next day it will buck me out of the truck.
Reply With Quote
  #4  
Old 02-05-2006
BOB BOB is offline
Member
 
Join Date: Nov 2005
Location: Haltom City , Texas
Posts: 208
Certainly sounds like driveline harmonic . Have you checked your driveshaft ? U-joints? You might crawl under and give it a shake . I'm sure you've already looked for bad tires , but it's worth mentioning. bob

Last edited by BOB; 02-05-2006 at 06:12 PM. Reason: another thought
Reply With Quote
  #5  
Old 02-05-2006
Member
 
Join Date: Dec 2005
Location: MI, U.S.A.
Posts: 322
I too would recommend checking the u-joints and the balancing of the wheels.
Reply With Quote
  #6  
Old 02-05-2006
04edge's Avatar
Member
Thread Starter
 
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
I have thought about it beeing the tires unbalanced but wouldnt it contantly vibrate at that speed instead of only doing it for a few seconds then going away. Altho you could be right my tires are in pretty bad shape I will bring it over to my friends and throw them on the balancer. And as for the drive shaft when i looked everything appeared ok. But who nows it could be out of wack. I will try giving it a shake and see what happens. The more I think about it dont think it is the tranny tho because it shifts fine and only vibes right after it shifts in O/D or after its been in O/D.
Reply With Quote
  #7  
Old 02-05-2006
Member
iTrader: (1)
 
Join Date: Mar 2005
Location: Acworth, GA
Posts: 2,099
It could be the torque covertor clutch spazzing out. But I have no idea why it would only do that at certain speeds. I have seen this happen, but it was as soon as it was in OD. Thats kind of why i'm leaning torwards the tires.
Reply With Quote
  #8  
Old 02-05-2006
Flyinfx4's Avatar
Member
 
Join Date: May 2005
Location: Colora, Maryland
Posts: 716
It could be he drive shaft cause i no when my front was going bad i had really bad vibration at like 30 to 35 mph and then it would stop so u might want to check them.
Reply With Quote
  #9  
Old 02-05-2006
04edge's Avatar
Member
Thread Starter
 
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
well I check the tires other than beening worn to **** they werent to off balance and i balanced them the best i could. I also check the drive shaft and it doesnt move when i shake it. My buddys dad thinks it the torque converter and my buddy thinks it might be the muffler because when his was shot it vibrated but his had holes rusted in it so i dont think its the problem. But I guess i get to make a lovely phone call to the dealer tomorrow.
Reply With Quote
  #10  
Old 02-06-2006
Member
iTrader: (1)
 
Join Date: Mar 2005
Location: Acworth, GA
Posts: 2,099
Lol its not the muffler. Haha.

It's probably the coverter clutch slipping.
Reply With Quote
  #11  
Old 02-06-2006
04edge's Avatar
Member
Thread Starter
 
Join Date: Jan 2005
Location: Beecher,IL
Posts: 512
Well my cousin is over and she told me her explore had the exact same problem and all the ford dealers around couldnt find what was wrong. But does any one have any ideas what a new converter would cost? I tried searching every ford part site i could and came up empty handed.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
I need a passenger seat badly! inavacuum Interior Semi-Tech 1 10-12-2010 02:54 PM
need help badly sideswipe General Technical & Electrical 4 08-09-2008 10:10 PM
Aggggh! My ranger is broken badly! Red_Ak_Ranger General Ford Ranger Discussion 32 10-21-2007 06:08 PM
oil change badly needed.. red_fx2 2.9L & 3.0L V6 Tech 12 09-02-2006 05:29 PM
Iam Stupid i need Help Badly SteveOh 4.0L OHV & SOHC V6 Tech 11 09-02-2005 11:29 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:56 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.