not running right - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-02-2013
Member
Thread Starter
 
Join Date: Feb 2013
Location: washington,pa
Posts: 87
not running right

2000 ranger 2wd 3.0 hose blow went all over engine got my coil pack soaked now got miss check engine light came on code says miss fire on 1 and 3 you think its the coil pack? runs good at 45 to 60 mph no miss at that speed
Reply With Quote
  #2  
Old 04-03-2013
phatspeed7x's Avatar
Member
 
Join Date: Jun 2006
Location: Hibbing MN
Posts: 384
Try replacing the coil. I found one on amazon for half price as the parts store. Seems to work fine.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
progress has been made but its still not running right. tde720 General Technical & Electrical 4 10-07-2014 05:00 PM
85 2.8l not running right jonathanhead 2.9L & 3.0L V6 Tech 4 03-15-2014 11:25 PM
97 ford ranger not running right fordman26 4.0L OHV & SOHC V6 Tech 0 09-13-2011 09:29 AM
Help 5.0 not running right. ford rules 8-Cylinder Tech 24 03-02-2010 02:32 PM
not running right ranger87 General Technical & Electrical 0 03-05-2008 09:26 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:42 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.