O2 problems ? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-23-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: Seabrook, Texas
Posts: 13
O2 problems ?

1998 single cab
2.5 5 speed

I've been getting alright gas mileage but I think it could be much better. Performance sucks! I've had the truck for a month or two. Did a full tune up. Plugs, wires, oil, filter-oil,air,fuel, Pcv...

The truck does not accelerate in 5th gear. Went to Dallas (4 hour drive) a week ago and on every hill I'd lose 10 MPH and that's at wot. The temp went up a little bit also. When accelerating anything over 3k the motor sounds like it wants to fall apart.

I got the solus out today and my O2mvs are reading crazy.
At an idle the upstream o2 jumps from 800, 730, 44, 0, 50, 250, 720, 30, 0, 800
At higher rpms the numbers are jumping around.

Downstream o2 is about 800 most of the time then drops to 30, 0 and back to 800.

Anyone seen this before?

Last edited by Sinic; 09-24-2010 at 06:53 PM.
Reply With Quote
  #2  
Old 09-24-2010
Member
Thread Starter
 
Join Date: Aug 2010
Location: Seabrook, Texas
Posts: 13
Well just in case anyone is having the same problem..

I replaced both o2s and now the mvs do not drop to 0. The downstream does not move around. The upstream goes up and down from about 40-800 which I believe is cool.

I've only drove a little but I believe gas mileage is already better. Idle is smoother and doesn't shake as much when a/c kicks on and off.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Clutch problems or Motor problems? Or both? JGod General Ford Ranger Discussion 3 02-08-2014 07:35 AM
Clutch problems...possibly?!?!? Help?? ZetaOmegaRanger 2.9L & 3.0L V6 Tech 2 01-04-2008 02:47 AM
Door dinger mod... now problems with blinkers? Zero General Technical & Electrical 4 09-28-2004 11:35 AM
Amp problems Skyjacker_44 Audio & Video Tech 3 08-31-2004 09:52 AM
Driver's side seat belt problems... 98blackranger Interior Semi-Tech 6 06-24-2004 02:07 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:09 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.