pressed brake = blinkers dont work - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-18-2011
STUPIDHEAD11's Avatar
Member
Thread Starter
 
Join Date: Oct 2010
Location: Melbourne, Florida
Posts: 219
pressed brake = blinkers dont work

I have no idea how or why but after a few minutes of experimenting with the problem i have dwindled it down to the brake. when the pedal is pressed the blinkers wont work
Reply With Quote
  #2  
Old 01-18-2011
annguyen1981's Avatar
Member
iTrader: (4)
 
Join Date: Apr 2009
Location: Chicopee, MA
Posts: 1,888
You really are determined to destroy that poor truck before you get rid of it in a few months, huh?


IDK if there's a flasher in these Rangers, but check that. Also check fuses.
Reply With Quote
  #3  
Old 01-18-2011
bud's Avatar
bud bud is offline
Member
 
Join Date: Jan 2011
Location: georgia
Posts: 41
Turn Signal Wiring Harness ??

Hi , I've seen this more than once over my 63 years ! The switch under your steering wheel has gone bad ?? Remove the wheel & unplug the wiring hasness below the wheel remove the whole turn signal switch with hand control & replace with new switch . This should solve your problem . My Thoughts Bud
Reply With Quote
  #4  
Old 01-18-2011
The SuperDookie Ranger's Avatar
Member
 
Join Date: Aug 2010
Location: Cincinnati, Ohio
Posts: 817
Don't do that yet, Check your fuses for a start, had the same problem on my SS. All it was, was a fuse.
Reply With Quote
  #5  
Old 01-19-2011
STUPIDHEAD11's Avatar
Member
Thread Starter
 
Join Date: Oct 2010
Location: Melbourne, Florida
Posts: 219
Quote:
Originally Posted by annguyen1981 View Post
You really are determined to destroy that poor truck before you get rid of it in a few months, huh?


IDK if there's a flasher in these Rangers, but check that. Also check fuses.
are you unable to make useful suggestions and pointers without preceding your honestly useful information with a dick comment or sarcastic and unneeded crap talk? just to be sure whether to actually read the first comment you make on any question I ask.

and it is a legitimate problem was it not? It is of no fault of mine but it just so happens that the trailer wire harness, after being dunked in saltwater, has started to corrode inside the harness. some how this was causing my tails and blinker, headlights etc to act really strange (backfeed). since i no longer own the boat i clipped the harness off and taped the exposed wire and waalaa. thank you anyways
Reply With Quote
  #6  
Old 01-19-2011
STUPIDHEAD11's Avatar
Member
Thread Starter
 
Join Date: Oct 2010
Location: Melbourne, Florida
Posts: 219
I did check all fuses and relays and bulbs before I did anything else. the trailer wire harness was causing the lights to backfeed and si after a removeing trailer wire the probllem is no more. thank you guys.
Reply With Quote
  #7  
Old 01-19-2011
annguyen1981's Avatar
Member
iTrader: (4)
 
Join Date: Apr 2009
Location: Chicopee, MA
Posts: 1,888
Glad it worked out for ya..





Boohoo
(see there? I put my "dick comment or sarcastic and unneeded crap talk" AFTER the sincere comment)

Was that better?
Reply With Quote
  #8  
Old 01-20-2011
STUPIDHEAD11's Avatar
Member
Thread Starter
 
Join Date: Oct 2010
Location: Melbourne, Florida
Posts: 219
very much so
Reply With Quote
  #9  
Old 01-20-2011
annguyen1981's Avatar
Member
iTrader: (4)
 
Join Date: Apr 2009
Location: Chicopee, MA
Posts: 1,888
I'm glad. :-)
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2003 Ford Ranger, Blinkers wont work but hazards and everything else does jay398 General Technical & Electrical 14 10-18-2017 09:08 AM
Rear axle housing, pressed in axle tubes jpsaxnc General Ford Ranger Discussion 4 06-05-2014 10:04 PM
Brake light / Blinkers 1996Ranger4x4SuperCabSTX General Ford Ranger Discussion 0 06-03-2010 09:45 PM
Blinkers wont work!!! crimsinx General Technical & Electrical 8 10-07-2009 05:22 PM
dont like jap / korean cars, dont open this thread. Melt Snapshots 26 01-23-2009 09:06 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:34 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.