Quick 4.0 v6 question - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-06-2011
rangerman94's Avatar
Member
Thread Starter
 
Join Date: Mar 2010
Location: Vancouver, Wa
Posts: 51
Quick 4.0 v6 question

Wasup,

Alright I own a 1994 Ford Ranger 4.0 V6 4x4 with about 210k miles and I have some runability issues. They started around 175k and have slowly become worse overtime. It runs and drives fine when its cold but when warmed up it drives ok not great but ok and if it sits for about thirdy minuets or so after driving it for a bit it sputters out and wont run unless I keep my foot in the gas peddal and hold it for about ten seconds before it can hold a decent idle so i can drive it but surges at a stop and seems to jump around 800 to 1000 and jumps while at a stop . I have read other questions with other owners with the some problem and I've changed plugs, wires, coil pack, fuel filter, cleaned the MAF, cleaned the idle air control valve and changed the fuel filter as others have recomended to fix the problem and have had no sucess . Not sure what to do now I am hoping someone has had this problem and fixed it.

Thanks for reading,

Matt
Reply With Quote
  #2  
Old 02-07-2011
Bwanaworker's Avatar
Member
iTrader: (3)
 
Join Date: Sep 2009
Location: St. Paul MN
Posts: 108
I haven't had this problem on a ranger but my 4.3 blazer had the same exact symptoms and it ended up being the EGR valve. I'm sure others will have some better advice but the EGR isn't a bad place to start.
Reply With Quote
  #3  
Old 02-07-2011
Redrocket's Avatar
Member
iTrader: (6)
 
Join Date: Jan 2007
Location: Waynesville n.c
Posts: 1,993
change the idel air valve cleaning em does no good
Reply With Quote
  #4  
Old 02-07-2011
rangerman94's Avatar
Member
Thread Starter
 
Join Date: Mar 2010
Location: Vancouver, Wa
Posts: 51
Alright cool I'll go buy the Idle Air Control Valve, then I'll look into the EGR valve. I personally don't know where the EGR is does anyone else?
Reply With Quote
  #5  
Old 02-08-2011
Redrocket's Avatar
Member
iTrader: (6)
 
Join Date: Jan 2007
Location: Waynesville n.c
Posts: 1,993
Wirelessly posted (droid)

Look for a tube coming off the drivers side mainfold then follow it up and theirs ya egr.. it should be mounted on the side of the intake on drivers side
Reply With Quote
  #6  
Old 02-28-2011
rangerman94's Avatar
Member
Thread Starter
 
Join Date: Mar 2010
Location: Vancouver, Wa
Posts: 51
Ok the IACV swap did the trick, I still get what feels like a miss or a sure if I run the defrost or run the ac. The truck runs fine when I have both turned off. Not sure what's wrong, by the way are all ranger 4.0's equiped with an EGR valve? I can't seem to find mine and a few of my tech friends can't seem to find it ether.
Reply With Quote
  #7  
Old 02-28-2011
Member
 
Join Date: Dec 2010
Location: Sterling, Oh
Posts: 117
you dont have egr... we pretty much have the same truck and mine does the same thing
Reply With Quote
  #8  
Old 02-28-2011
Redrocket's Avatar
Member
iTrader: (6)
 
Join Date: Jan 2007
Location: Waynesville n.c
Posts: 1,993
some had a egr valve some didnt
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
quick question about Brakecleen, need quick answer if possible 93rangerXLT4x4 Auto Detailing 101 15 11-28-2009 10:24 PM
Quick Trans question, need help quick dmathews 2.9L & 3.0L V6 Tech 0 11-15-2009 02:30 PM
quick question real quick dantheman General Ford Ranger Discussion 3 05-16-2009 01:52 AM
quick question Diabolic Ranger-Forums Office 10 02-17-2005 03:23 PM
Quick Question FORZDA General Technical & Electrical 6 02-07-2005 02:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:29 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.