So how long did your stock battery last? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-09-2009
Sonic04Edge's Avatar
RF Veteran

Thread Starter
iTrader: (6)
 
Join Date: Jun 2004
Location: Madison. AL
Posts: 5,715
Icon5 So how long did your stock battery last?

Well my completely crapped out on me last night unexpectedly. I was at work and was heading out on a run and stopped to get some gas. Filled it up and went to go start it and I got NOTHING at all. It had started fine literally 5 minutes before. It sucked because I had to spend money I didn't have for a batter, but at the same time it lasted me a long time.

Got almost exactly 5 years out of it and 76k miles. 3 years was doing delivery so it had to start my truck a LOT. So anyway how long did yours last?
Reply With Quote
  #2  
Old 04-09-2009
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
I got about 5 years and 80K. It didn't crap out all the way but the starter was sounding really week and my stereo would reset all the settings.
Reply With Quote
  #3  
Old 04-09-2009
freddie's Avatar
Member
iTrader: (9)
 
Join Date: Apr 2007
Location: OH
Posts: 2,463
Quote:
Originally Posted by Sonic04Edge View Post
Well my completely crapped out on me last night unexpectedly. I was at work and was heading out on a run and stopped to get some gas. Filled it up and went to go start it and I got NOTHING at all. It had started fine literally 5 minutes before. It sucked because I had to spend money I didn't have for a batter, but at the same time it lasted me a long time.

Got almost exactly 5 years out of it and 76k miles. 3 years was doing delivery so it had to start my truck a LOT. So anyway how long did yours last?
That sounds more like a loose cable than a battery, especially if it just started fine right before that. Did you check to make sure the battery cables had a good connection?
Reply With Quote
  #4  
Old 04-09-2009
seed60's Avatar
RF Veteran
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
I just replaced mine at about 100k in my 03.

I think the only reason it crapped out was I kept running it down by accident, listening to the radio with the truck off, and I'm sure those short runs after using the winch didn't help it at all. It just got to the point were it wouldn't hold a charge.

But it did me good for a long time though. Motorcraft battery FTW!! lol
Reply With Quote
  #5  
Old 04-09-2009
camodown's Avatar
Lost in Nowhere
iTrader: (3)
 
Join Date: Feb 2007
Location: Midland, TX
Posts: 5,029
replaced mine last summer, 76K

That is running 6 spotlights and such quite a bit too
Reply With Quote
  #6  
Old 04-09-2009
CBFranger's Avatar
Member
 
Join Date: May 2008
Location: Tampa Bay Area
Posts: 1,029
55,000 or so. It still started when I replaced it but it was getting weak.
Reply With Quote
  #7  
Old 04-09-2009
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
I got about 55k out of mine. lol. I think i put the optima in it in '06?

Last edited by Fx4wannabe01; 04-09-2009 at 02:16 PM.
Reply With Quote
  #8  
Old 04-09-2009
Member
 
Join Date: Jul 2007
Location: Ohio
Posts: 737
I've got 39,000+ miles on my 2003 Ranger, so it's 6 years old. It has a Motorcraft battery which looks like it's original. I checked the little glass gauge and it shows green, so it's still good for now.

I haven't had any problems with it at all.
Reply With Quote
  #9  
Old 04-09-2009
RangerMuse's Avatar
Member
 
Join Date: Jul 2007
Location: Colorado
Posts: 1,727
Mine lasted 5 yrs and 50k miles.

Same thing that happened to you happened to me Mike, started fine. Drove it around. Stopped for ten min and it was done.

So now I have an optima red top FTMFW
Reply With Quote
  #10  
Old 04-09-2009
Machine090767's Avatar
RF Veteran
 
Join Date: May 2006
Location: Minnesota
Posts: 6,410
not sure how many miles it was, but the battery was 6 years old
Reply With Quote
  #11  
Old 04-09-2009
Member
 
Join Date: Jul 2007
Location: Ohio
Posts: 737
I read on another forum that somebody got 8 years out of his.
Reply With Quote
  #12  
Old 04-09-2009
01_ranger_4x4's Avatar
Member
iTrader: (4)
 
Join Date: Mar 2009
Location: Muskegon, Michigan
Posts: 3,585
eh, about 4 years
Reply With Quote
  #13  
Old 04-09-2009
zabeard's Avatar
who?
iTrader: (8)
 
Join Date: Nov 2004
Location: IN
Posts: 26,045
about 5 years.
Reply With Quote
  #14  
Old 04-09-2009
Sonic04Edge's Avatar
RF Veteran

Thread Starter
iTrader: (6)
 
Join Date: Jun 2004
Location: Madison. AL
Posts: 5,715
Quote:
Originally Posted by freddie View Post
That sounds more like a loose cable than a battery, especially if it just started fine right before that. Did you check to make sure the battery cables had a good connection?
Yeah the connection was good. Even after being jumped off twice it just didn't have anything left in it. As soon as the new battery was put in it started quicker and smoother.
Reply With Quote
  #15  
Old 04-09-2009
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Mine lasted up until last fall. Around 8 years and 229,xxx km's on it. (That's around 124K miles for our neighbours). Truck was built in October 2000, Original Motorcraft battery with 2000 year sticker on it. Truck wouldn't start after a night of sitting. The little window was still green, but it was faint. Just didn't want to hold a charge anymore.
Reply With Quote
  #16  
Old 04-09-2009
bucky919's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2006
Location: Minot, ND
Posts: 1,943
When I sold my ranger it still had the original in it, but in the F150 mine took a dump on me, when it was 30 below zero, so I had a optima in the garage that I put in...
Reply With Quote
  #17  
Old 04-09-2009
Ace's Avatar
Ace Ace is offline
Member
iTrader: (4)
 
Join Date: Aug 2007
Location: Central, Illinois
Posts: 3,448
6 years and 97k miles
Reply With Quote
  #18  
Old 04-09-2009
JoshK's Avatar
Member
 
Join Date: Sep 2006
Location: CC, Indiana
Posts: 3,832
Was on almost 5 years and 80k miles, then I stold it.

It also had a lot of ax. music time on it and even some sub time
Reply With Quote
  #19  
Old 04-09-2009
jtslmn720's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Location: Kent State, Kent Ohio
Posts: 7,367
ill let you know, 110k and still stock, ive drained it tons of times too so i really need a new one but i dont have the extra 100$ right now
Reply With Quote
  #20  
Old 04-09-2009
Member
 
Join Date: Sep 2007
Location: America
Posts: 24
Quote:
Originally Posted by dj wayne View Post
I read on another forum that somebody got 8 years out of his.
The stocker was still in there when I replaced the battery at 71k in 2007. I have a 98.
Reply With Quote
  #21  
Old 04-09-2009
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
4 years and 60k miles. Mine did the exact same thing, was working fine one minute then wouldn't start the next. It wouldn't jump off of a Suburu, I had a to use a SUV.
Reply With Quote
  #22  
Old 04-09-2009
blueranger789's Avatar
Member
 
Join Date: Mar 2009
Location: Boiling Springs, SC
Posts: 619
had the truck about 7 months before the bat cut out, but i bought it used so i dont know how long it lasted, sucked cause i was at home and had two others cars that i could of driven but i blocked them in the carport with the truck, had to push it through the yard
Reply With Quote
  #23  
Old 04-09-2009
Member
 
Join Date: Jul 2007
Location: Ohio
Posts: 737
I've read that some of Motorcraft batteries have a warranty for 8 years. Some dealers won't honor it if the vehicle's main warranty has expired.
Reply With Quote
  #24  
Old 04-09-2009
Jimmeh's Avatar
Member
iTrader: (1)
 
Join Date: Dec 2007
Location: Columbia Falls, MT
Posts: 3,224
Quote:
Originally Posted by dj wayne View Post
I've read that some of Motorcraft batteries have a warranty for 8 years. Some dealers won't honor it if the vehicle's main warranty has expired.
Well, they won't give you a new battery if it just plain wears out. Which I agree with.
Reply With Quote
  #25  
Old 04-09-2009
DisturbedESV's Avatar
Member
 
Join Date: Apr 2008
Location: Seattle, WA
Posts: 3,115
I got about 6 years out of my '99... 100K
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How long since your last 'mod'? And what was it? FMD General Ford Ranger Discussion 23 11-07-2012 02:25 PM
How long did it take you to buy your first mod? FULLSCALE General Ford Ranger Discussion 31 11-25-2010 09:27 PM
How long did your mud tires last? silverbullet32 Wheels & Tires Semi-Tech 23 08-01-2009 05:35 PM
how long do the 3.0's last? boog 2.9L & 3.0L V6 Tech 67 12-14-2007 11:56 PM
man, LONG last couple of days with the truck RangerBoy02FX4 General Ford Ranger Discussion 6 08-02-2006 09:49 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:19 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.