Spark plug discoloration - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-22-2006
b3kbruiser's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: DFW Area, Tx
Posts: 713
Spark plug discoloration

Weird problem going on... I just hope it's not a head gasket leak... Ok so here's what's going on, my truck has been sluggish (read, extra sluggish for a 3.0), so today I was going to do a compression test, but I guess I bought the wrong size or something (14mm) because I absolutly cannot get the damn thing to screw in!!! Anyways, I did take a good look at acouple of my spark plugs, and I've never seen the like... The number 4 cylinder (right side, back of engine) gave a a plug where the ceramic was 1/2 black, 1/2 normal white. I took a pic...


Sorry for the crappy quality, it was on my phone. It doesn't show up too too well but you get the idea. I pull the plug out of cylinder 5 and it was 1/2 white, 1/2 tan, like a much lighter shade of 4's plug... I pulled a plug from the cylider right across the engine on the other side (trying to rule out a head gasket problem by going to a different head) and it too was 1/2 tan 1/2 white...

What the heck is going on? How much would a shop charge for a compression test? Maybe $30? More, less? Any ideas what's going on? Running rich/lean because of some sensor problem, ect...

Thanks!
Reply With Quote
  #2  
Old 12-22-2006
Blessed98's Avatar
Member
 
Join Date: Dec 2006
Location: Pa
Posts: 58
I don't think it's a head gasket problem based on that picture. Rich plugs will be covered with carbon and black. Lean plugs will be more light colored. Oil on plugs looks like oil basically. I'm leaning toward it being a sensor/computer problem. I always try running fuel system cleaner through mine every once in a while and I have not changed my plugs once since I owned my truck. I did buy some of that CRC MAF sensor cleaner and clean the MAF off.
Reply With Quote
  #3  
Old 12-22-2006
b3kbruiser's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: DFW Area, Tx
Posts: 713
My father suggested buying mid-grade fuel... Would that help? Not all to long ago, I had taken it into a shop for a diagnosis and they said a scan returned an error at the spark plugs (the last shop had gapped them wrong) so I'm assuming that they found no other errors?
Reply With Quote
  #4  
Old 12-22-2006
ranger's Avatar
Member
 
Join Date: Jun 2006
Location: Imperial Beach, CA
Posts: 4,502
did you re gap them?
Reply With Quote
  #5  
Old 12-22-2006
b3kbruiser's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: DFW Area, Tx
Posts: 713
Of course
Reply With Quote
  #6  
Old 12-23-2006
CadiLLacPimPin's Avatar
Member
 
Join Date: Nov 2006
Location: Charlottesville, VA
Posts: 239
Carbon deposits usually mean its running a little rich, or the ignition system is weakening. Try some fuel injector cleaner in the tank with your next fill up.
How long has it been since the plug wires were last replaced?
Does it misfire or stutter any when you first start it or when its idleing at low engine speed?
Reply With Quote
  #7  
Old 12-23-2006
b3kbruiser's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: DFW Area, Tx
Posts: 713
Idle is a little rough, don't know why. Wires are new, less than 1,000 miles. The engine doesn't missifre at all, but if I start it and while the engine is cold (ie: sitting for more than 2 hours) and I punch the gas it will skip for a second and then rev.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ranger 2.3 Engine swap 8 plug to 4 plug, help! rangerdanger9419 SOHC - 2.3L & 2.5L Lima Engines 0 08-11-2015 04:02 PM
How do the plug wires go? - 1991 2.3 8 plug yamahondarider SOHC - 2.3L & 2.5L Lima Engines 1 04-29-2013 04:51 PM
Plug and Plug Wires Recommendations? brow_tines 4.0L OHV & SOHC V6 Tech 2 04-06-2011 03:09 PM
Black Fender Flare Discoloration (PIC) mazzman Exterior Semi-Tech 12 06-07-2008 11:59 AM
HELP!! 2.3 dual plug intermittent spark!! axel21071 SOHC - 2.3L & 2.5L Lima Engines 8 11-10-2005 05:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:31 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.