Truck Won't Start After Domelight Install - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 12-10-2005
r0ng5's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2004
Location: LA, CA
Posts: 2,575
Quote:
Originally Posted by Rangerboy03lvl2
battery terminal sealer .... and make sure your battery cables are connected tightly to the battery ... a loose connection will cause that ...
Thanks. They are actually REALLY tight, but i dont' know, maybe they can be tighter. Thanks
Reply With Quote
  #27  
Old 12-10-2005
Member
 
Join Date: May 2004
Location: McKinney, TX
Posts: 2,123
Autozone sells felt pads for 99 cents that slip on the posts. I don't know how they work, but they do a good job of keeping down corrosion. That and some sealer, and you should be good.
Reply With Quote
  #28  
Old 12-10-2005
Roach2004's Avatar
RF Veteran
iTrader: (3)
 
Join Date: May 2005
Location: Houston, TX
Posts: 8,320
Hmm I didnt have to wire mine either you should have bought an early 04! Well I am glad you got it all worked out!
Reply With Quote
  #29  
Old 12-11-2005
FauX's Avatar
Member
 
Join Date: Jun 2004
Location: Las Vegas, NV
Posts: 992
Go to autozone and get some battery terminal cleaner and some batter terminal protector. They come in spray cans. Spray the cleaner on, wait about a minute and scrape it all off with a wire brush. Then lightly wash it off, blow dry the terminals dry and spray the protector on, should last quite some time. Mine has lasted over a year and still no corrosion.
Reply With Quote
  #30  
Old 12-11-2005
LILBLUE04FX4L2's Avatar
Member
 
Join Date: Jun 2004
Location: Exit 105 New Jersey
Posts: 2,409
clean terminals and posts very well
you need to get down to fresh lead contact
coat in dielectric grease and tighten fully
this special grease helps transmit current and will seal and protect the terminals
don't use regular grease - that will only hurt over time
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Incorrect jump start. Truck won't start now. Pilot General Technical & Electrical 3 10-27-2013 08:07 AM
Very weird! Won't start, won't shut off, flashing exterior lights fletcher969 2.9L & 3.0L V6 Tech 4 01-14-2013 06:26 PM
My 00 ranger won't start after it as been running a while lka1983 SOHC - 2.3L & 2.5L Lima Engines 0 11-11-2010 06:23 PM
Will crank but won't start after tranny install hckymstr21 General Technical & Electrical 4 09-05-2010 07:41 PM
Truck won't start after checking fuses and relays. Did I mess something up? Jwad00 General Technical & Electrical 6 09-03-2009 06:19 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:52 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.