WHAT!? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-27-2009
BCobe's Avatar
Member
Thread Starter
 
Join Date: Jul 2008
Location: Fairfeild,California
Posts: 1,055
WHAT!?

After 6 months I came back and took my truck out of storage.. When I left it I left it with no bugs or problems. When I get in it a couple weeks ago for the first time and the engine lights on. I had to put gas in it and Isk what happend some of it like straight squirted out.. I kinda ruled that as some sort of venting problem. Now yesterday my gas cap light came on also even though its tight as sh*t... Anyone have this problem or know whats up? All the hoses look ok so idk whats up..
Reply With Quote
  #2  
Old 12-27-2009
dangelj316's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2006
Location: Yuma, AZ
Posts: 813
Did you put any type of fuel stabilizer in the gas tank before you put it in storage?
Reply With Quote
  #3  
Old 12-27-2009
BCobe's Avatar
Member
Thread Starter
 
Join Date: Jul 2008
Location: Fairfeild,California
Posts: 1,055
Yea
Reply With Quote
  #4  
Old 12-27-2009
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
gas cap prob has a venting problem for the one issue go buy a new stant cap from the auto store
Reply With Quote
  #5  
Old 12-27-2009
MothMan999's Avatar
Member
iTrader: (3)
 
Join Date: Mar 2009
Location: Chantilly, VA
Posts: 858
Stant part number is 10832. If your flex fuel its 10832Y.
Reply With Quote
  #6  
Old 12-27-2009
dangelj316's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2006
Location: Yuma, AZ
Posts: 813
No idea then.
Reply With Quote
  #7  
Old 12-27-2009
BCobe's Avatar
Member
Thread Starter
 
Join Date: Jul 2008
Location: Fairfeild,California
Posts: 1,055
I know like half of the fuel stabelizer spilled... Does that mean anything?
Reply With Quote
  #8  
Old 12-27-2009
dangelj316's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2006
Location: Yuma, AZ
Posts: 813
Your fuel might be bad. Have you gased up yet, since you've been back? When i would go on deployments, i would always put "Stabil" in my tank to keep the fuel good. Otherwise the fuel can go bad and mess some things up.
Reply With Quote
  #9  
Old 12-27-2009
BCobe's Avatar
Member
Thread Starter
 
Join Date: Jul 2008
Location: Fairfeild,California
Posts: 1,055
Yea I have alot because I have been doing some drivin... Yea I put "stabi" in it but like I said like half of it spilled out.. Would of bought more BUT I was leaving early in the AM the next day
Reply With Quote
  #10  
Old 12-27-2009
dangelj316's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2006
Location: Yuma, AZ
Posts: 813
Well, it should be flushed out then. . . . . maybe buy some fuel system cleaner, and hopefully it should be fine after.
Reply With Quote
  #11  
Old 12-27-2009
BCobe's Avatar
Member
Thread Starter
 
Join Date: Jul 2008
Location: Fairfeild,California
Posts: 1,055
Yea Ill go buy some stuff today... Thanks bro!
Reply With Quote
  #12  
Old 12-27-2009
dangelj316's Avatar
Member
iTrader: (1)
 
Join Date: Feb 2006
Location: Yuma, AZ
Posts: 813
Yeah man.
Reply With Quote
  #13  
Old 12-27-2009
Rangerguy's Avatar
Member
 
Join Date: Feb 2008
Location: California
Posts: 1,120
Welcome back man, glad you made it home safe. Sounds like the gas went bad. Truck is looking really dam nice bud!
Reply With Quote
  #14  
Old 12-27-2009
BCobe's Avatar
Member
Thread Starter
 
Join Date: Jul 2008
Location: Fairfeild,California
Posts: 1,055
Yea thanks mark its deffenitly good to be back

But I ran some seafoam through the tank and went to fill up and It still wants to spit out fuel.. If I go real slow it fine its when I go fast it wants to spit. Also the check engine light is on so Idk if that has anything to do with it but I disconected my Batt to reset the code and the fuel cap one went off but the check engine is still on. It might be bad gas but I have refueled a whole hell of a lot of times. Its like half a tank if I want to go anywhere
Reply With Quote
  #15  
Old 12-27-2009
Thorny073's Avatar
Member
 
Join Date: May 2008
Location: California, Ky
Posts: 621
The gas is squirting out of the tank back up the filler neck...then its probally something clogged up on the EVAP system, the vent solenoid may not be working properlly
Reply With Quote
  #16  
Old 12-29-2009
hozII's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: athens, Al
Posts: 2,245
might as well run by the dealer and pick up there version of seafoam..works better than the actual seafoam...lol!!
Reply With Quote
  #17  
Old 12-29-2009
01_ranger_4x4's Avatar
Member
iTrader: (4)
 
Join Date: Mar 2009
Location: Muskegon, Michigan
Posts: 3,585
did you pull the code to see what it was? my truck did something simular after it sat for a year when i was in iraq. these trucks get pissy if you dont drive them. i had a CEL, two leaky axle seals and a bad battery when i got home lol. where was it stored?
Reply With Quote
  #18  
Old 12-30-2009
pacodiablo's Avatar
Member
 
Join Date: Jun 2004
Location: Charlotte, NC
Posts: 1,126
Pull the code. It definitely sounds like something is messed up with the EVAP system. It may just be something simple though.

I got a check fuel cap light a while back with a code for an EVAP leak. It turns out the vacuum line for the charcoal canister purge valve had come loose. I plugged it back up and it was fine. I'm not saying this is your problem, it's just an example of how it can be something stupid.
Reply With Quote
  #19  
Old 12-30-2009
bjohnson238's Avatar
Member
 
Join Date: Nov 2008
Location: Muncie, IN
Posts: 732
Sounds like spiders or something could have built a little nest in the vent tube while it was parked keeping the evap from working properly.
Reply With Quote
  #20  
Old 01-05-2010
Rangerguy's Avatar
Member
 
Join Date: Feb 2008
Location: California
Posts: 1,120
Yeah, find out what the code is and that will narrow down your potential problem a lot.
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:12 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.