The "What did you do to your Ranger today" thread - Page 91 - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #2251  
Old 01-25-2011
Bart68's Avatar
Member
 
Join Date: Oct 2007
Location: Kamloops B.C.
Posts: 129
I had a Compustar Alarm and remote starter installed yesterday and this morning I changed the tensioner and Idler pullies and the fan belt.
Reply With Quote
  #2252  
Old 01-25-2011
Member
 
Join Date: Aug 2009
Location: Okeechobee,FL / Singapore
Posts: 563
Drove it the first time in about 2 weeks... No water leaking... wonder if its the damn heater hose / heat core that I can't find it leaking until it gets hot enough or something... Guess I will just have to keep it while I wait for my new truck...
Reply With Quote
  #2253  
Old 01-25-2011
Timberwolf's Avatar
Member
 
Join Date: Oct 2010
Location: East coast Canada
Posts: 706
Well, I put a AAL kit on my rig today. Sits and looks sweet. Exactly what the rear needed. I will post some pics tomorrow.
Reply With Quote
  #2254  
Old 01-25-2011
01DangerRanger's Avatar
Member
 
Join Date: Oct 2010
Location: Melbourne, Florida
Posts: 983
Quote:
Originally Posted by Y2KTJ View Post
Drove it the first time in about 2 weeks... No water leaking... wonder if its the damn heater hose / heat core that I can't find it leaking until it gets hot enough or something... Guess I will just have to keep it while I wait for my new truck...
new truck???
Reply With Quote
  #2255  
Old 01-26-2011
Member
 
Join Date: Feb 2010
Location: Cocoa, FL
Posts: 555
Yesterday, I took some pictures of her flexed out, got buried in some sugar sand, well framed, had my buddy in his Chevy come pull me out and romped through over a foot of water, and almost hydrolocked the 302.

When all I planned on doing was taking flex pictures.

Haha
Reply With Quote
  #2256  
Old 01-26-2011
Jelly's Ford's Avatar
Member
iTrader: (3)
 
Join Date: Mar 2010
Location: KnoxVegas, TN
Posts: 874
Took the throttle body off and cleaned the whiz out of it today; now it's nice and shiny, and sprayed a ton of throttle body cleaner into the intake along with adding yet again another zip tie to the throttle cable b/c of slack. Dang that throttle body had been neglected. The truck idles and takes off so much smoother now.
Reply With Quote
  #2257  
Old 01-26-2011
STUPIDHEAD11's Avatar
Member
 
Join Date: Oct 2010
Location: Melbourne, Florida
Posts: 219
^ did the same thing...go figure. cleaned entire intake sytem from box to block. used a fishing weight and fishing line and an old towel like a barrel cleaner and dragged it through the intake tube...haha it actually worked. the towel was black
Reply With Quote
  #2258  
Old 01-26-2011
Backinthefold's Avatar
Member
 
Join Date: Jan 2011
Location: Arvada, Colorado
Posts: 19
Took it to the neighborhood Ford Fix it Shop to have a new clutch put in. Wanted to take a crack at installing a new one myself but it was lightly snowing this morning and a one car garage makes that job sound just a little un-appetizing.
Reply With Quote
  #2259  
Old 01-26-2011
Member
 
Join Date: Aug 2009
Location: Okeechobee,FL / Singapore
Posts: 563
Quote:
Originally Posted by 01DangerRanger View Post
new truck???
Ordering a 2011 FX4 F-150....
Reply With Quote
  #2260  
Old 01-26-2011
thadirty530's Avatar
Member
 
Join Date: Dec 2010
Location: West Valley UT
Posts: 84
tore apart my front end, went out and bought new fasteners to hold my new djm drop kit in place which should be here tomorrow yay!
Reply With Quote
  #2261  
Old 01-27-2011
Member
 
Join Date: Aug 2009
Location: Okeechobee,FL / Singapore
Posts: 563
Washed it... kinda... Was washing the boat and splashed crap on it so I ended up washing the bed / topper of it.. Attached it to the boat so I can go fishing in the am....
Reply With Quote
  #2262  
Old 01-28-2011
Member
 
Join Date: Feb 2010
Location: Cocoa, FL
Posts: 555
Icon6

Threw on my new 5.0 badges, made a splash guard for my dizzy and carb.
Reply With Quote
  #2263  
Old 01-28-2011
01DangerRanger's Avatar
Member
 
Join Date: Oct 2010
Location: Melbourne, Florida
Posts: 983
Quote:
Originally Posted by Y2KTJ View Post
Ordering a 2011 FX4 F-150....
keepin the ranger?
Reply With Quote
  #2264  
Old 01-28-2011
Member
 
Join Date: Jan 2010
Location: West Allis, WI
Posts: 16
Yay I tinted my front windows to match the rears! and put gas in it!.... exciting I know...
Reply With Quote
  #2265  
Old 01-28-2011
Member
 
Join Date: Aug 2009
Location: Okeechobee,FL / Singapore
Posts: 563
Drove to the ramp, took the boat out for 5 hours, froze my butt off, pulled the boat out, washed it again, now we sit and wait until we can fish again in the morning...

Pat if they give me enough on trade its theirs... If not its getting a new motor and going to the father in laws until I want to play with it again.

Anyone know if the new Eco-boost will fit in an Edge frame?
Reply With Quote
  #2266  
Old 01-28-2011
WillInThe04Ranger's Avatar
Member
 
Join Date: Oct 2009
Location: Rocky Mount, NC
Posts: 666
oooo I get to update and say I did the Flat tire mod a while back hahaha
Reply With Quote
  #2267  
Old 01-28-2011
RANGER1416's Avatar
Member
 
Join Date: Jan 2010
Location: waynesville,nc
Posts: 94
moved my amp
Reply With Quote
  #2268  
Old 01-29-2011
cmaskel's Avatar
Member
 
Join Date: Oct 2010
Location: somersworth new hanpshire
Posts: 18
Got It back after letting my stepfather borrow it and crazy girlfriend got drunk and destroyed my interior and broke my mirrors off hes in jail shes no where to be found gas I am paying for my self nobody but me will ever drive my truck again
Reply With Quote
  #2269  
Old 01-29-2011
Taylor's Avatar
Ive been dubbed....an old volk
iTrader: (18)
 
Join Date: Mar 2010
Location: Nashville, NC
Posts: 7,110
^thats not good.

Did the lube the back of front brake pads mod. Worked great. No more squeal.

Only got passenger side though. Will get driver tomorrow.
Reply With Quote
  #2270  
Old 01-29-2011
Rangerguy's Avatar
Member
 
Join Date: Feb 2008
Location: California
Posts: 1,120
Cleaned the interior after a few days on the road. Feels much better
Reply With Quote
  #2271  
Old 01-29-2011
Member
 
Join Date: Jan 2011
Location: Columbia, Ms.
Posts: 38
Changed oil, installed k&n air filter, changed battery terminals, went to crank it up and click.....nothing. So, I went to charge my battery and it started to swell. I'll just have to buy a new battery tomorrow. Not a good day.
Reply With Quote
  #2272  
Old 01-29-2011
j99ranger4x4's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: Delaware, OH
Posts: 1,381
got rid of a hanging back up light, started wire looming wiring to the other back up light, put my spare tire back underneath the truck after i painted the wheel while it was still decent, realigned my header panel cuz it was off, started to rewire my kc lites (wiring got screwed up in a wreck).
Reply With Quote
  #2273  
Old 01-30-2011
ranger beater's Avatar
Member
 
Join Date: Feb 2009
Location: Ocala Florida
Posts: 68
Put EBC rotors and pads on today, awsome upgrade.
Reply With Quote
  #2274  
Old 01-30-2011
TheRedRanger01's Avatar
Member
 
Join Date: Jul 2010
Location: San Antonio, TX
Posts: 200
Fixed my off road lights after I figured out the was a short in the positive power wire.
Reply With Quote
  #2275  
Old 01-30-2011
Taylor's Avatar
Ive been dubbed....an old volk
iTrader: (18)
 
Join Date: Mar 2010
Location: Nashville, NC
Posts: 7,110
cut off exhaust tips.

Lubed driver side brakes.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
The "What do you hate about your Ranger today" thread winks General Ford Ranger Discussion 172 09-12-2016 10:07 AM
The "What do you hate today about your Ranger" thread. dcrymes99ranger General Ford Ranger Discussion 32 10-08-2010 04:01 PM
"what did you do today....should be a category in the forums list dixie_boysles Ranger-Forums Office 6 05-26-2009 10:34 PM
For people with the "shorty" console.....where did you place you switches in/on it? lifted97ranger General Technical & Electrical 13 12-30-2007 10:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:51 PM.