What's bright yellow, slippery, and all over the place? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-27-2008
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
What's bright yellow, slippery, and all over the place?

I got my body lift installed and didn't notice a hose rubbing. Anyways the hose busted and leaking flourescent greenish yellow liquid. It looks like it connects back to the air conditioner. Does anyone know what this fluid might be?

I've got the stuff to fix the hose, but I'm unsure on what that fluid is. Any help?
Reply With Quote
  #2  
Old 07-27-2008
wyldechild's Avatar
Member
 
Join Date: Jun 2007
Location: Denver, Colorado
Posts: 1,952
Radiator antifreeze/coolant would be my guess
Reply With Quote
  #3  
Old 07-27-2008
06fx4 L2's Avatar
Member
 
Join Date: Mar 2007
Location: SO CAL
Posts: 430
ya thats the only yellow green fluid in a car. probably going to the heater core i would assume. that sucks what did it rub on?
Reply With Quote
  #4  
Old 07-27-2008
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
Probably the AC lines from the compressor rubbing on the serp. belt.

You gotta watch what your doing when doin the lift...it says to watch out for those lines in the instructions. Bend them, ziptie them, or use the bracket in thte kit to help get them out of the way.
Reply With Quote
  #5  
Old 07-27-2008
Member
iTrader: (1)
 
Join Date: Jun 2008
Location: Livonia, MI
Posts: 489
Thats prolly not antifreeze, thats prolly A/C compressor oil, AKA Pag oil, you need that in your A/C system to keep everything Lubricated.
Reply With Quote
  #6  
Old 07-27-2008
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
I'm not sure. It doesn't really smell like antifreeze and it's coming out pure, not diluted with water or anything. I took some pics.


This is were it was rubbing on the belt. Hose already cut.


This is the hose up top.


The fluid.
Reply With Quote
  #7  
Old 07-27-2008
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
I think you guys are right about it being part of the AC.

Must of skipped that page in the lift intructions. oops!
Reply With Quote
  #8  
Old 07-27-2008
Member
iTrader: (1)
 
Join Date: Jun 2008
Location: Livonia, MI
Posts: 489
Ya, Thats not antifreeze, Thats Pag oil for your A/C compressor.
Reply With Quote
  #9  
Old 07-27-2008
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
Any special type I should put back in? I need to figure out how to fill it back up!?!

Thanks for the quick help.
Reply With Quote
  #10  
Old 07-27-2008
Member
iTrader: (1)
 
Join Date: Jun 2008
Location: Livonia, MI
Posts: 489
you probably haveto unbolt the A/C manifold from the back of the A/C compressor and pour it in there. I beleive it takes PAG 150 which can be bought at any Auto Part Store. Just be sure not to fill it to full, The more oil the worse the A/C works because it restricts the flow of the Freeon, ask the store you go to how much oil it needs.
Reply With Quote
  #11  
Old 07-27-2008
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Ah the body lift gods got another AC line! I made sure to check mine, I still didn't know if it was gonna catch when I cranked it or not tho lol
Reply With Quote
  #12  
Old 07-27-2008
FullThrottle02's Avatar
Member
iTrader: (3)
 
Join Date: Apr 2008
Location: McHenry,IL
Posts: 586
You need to go to a shop(Ford Dealer) and have them properly charge your a/c system. You not only lost the PAG oil but you lost all of the refrigerant. The only way to properly get the refrigerant and proper amount of oil back in the system is with an a/c machine. You will also need to replace that line.

Jason
Reply With Quote
  #13  
Old 07-27-2008
graniteguy's Avatar
Member
iTrader: (3)
 
Join Date: Jul 2005
Location: Texas
Posts: 3,221
The same thing happened to me. Replaced the line and recharge the system. It'll add close to $200 to you B/L cost. I think the line is $125. I used an A/C recharge kit to put the freon back in. That was probably $50 or more.
Reply With Quote
  #14  
Old 07-27-2008
Hanzo Steel's Avatar
Member
 
Join Date: Dec 2006
Location: Aurora, Co/SFV, Ca.
Posts: 593
I agree, thats not something you wanna mess with yourself and get it wrong.
Reply With Quote
  #15  
Old 07-27-2008
wyldechild's Avatar
Member
 
Join Date: Jun 2007
Location: Denver, Colorado
Posts: 1,952
Quote:
Originally Posted by Rangerkid View Post
Thats prolly not antifreeze, thats prolly A/C compressor oil, AKA Pag oil, you need that in your A/C system to keep everything Lubricated.


yeah, my bad. those pictures make it clear that it is the Pag oil
Reply With Quote
  #16  
Old 07-27-2008
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Sweet, we got 3 more BLed trucks in like 2 weeks for NC haha
Reply With Quote
  #17  
Old 07-27-2008
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
I've fixed the hose



Just need to get it filled back up.

Thanks for all the help.
Reply With Quote
  #18  
Old 07-27-2008
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Nicely done!
Reply With Quote
  #19  
Old 07-27-2008
Member
iTrader: (1)
 
Join Date: Jun 2008
Location: Livonia, MI
Posts: 489
Is that the A/C rated hose or is that just heater hose? They make a special hose that doesn't deteriorat from the freeon and oil that goes through the system.
Reply With Quote
  #20  
Old 07-27-2008
Ace's Avatar
Ace Ace is offline
Member
iTrader: (4)
 
Join Date: Aug 2007
Location: Central, Illinois
Posts: 3,448
Quote:
Originally Posted by 04blackedge View Post
Sweet, we got 3 more BLed trucks in like 2 weeks for NC haha
** Note to self don't go to North Carolina to get my BL installed
Reply With Quote
  #21  
Old 07-27-2008
DisturbedESV's Avatar
Member
 
Join Date: Apr 2008
Location: Seattle, WA
Posts: 3,115
Quote:
Originally Posted by Ace View Post
** Note to self don't go to North Carolina to get my BL installed
x2
Reply With Quote
  #22  
Old 07-27-2008
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Quote:
Originally Posted by Ace View Post
** Note to self don't go to North Carolina to get my BL installed
What is that supposed to mean...
Reply With Quote
  #23  
Old 07-27-2008
seed60's Avatar
RF Veteran
Thread Starter
iTrader: (15)
 
Join Date: Jun 2008
Location: Mooresville, NC
Posts: 5,584
Quote:
Originally Posted by Ace View Post
** Note to self don't go to North Carolina to get my BL installed
Or atleast don't have me do it!! lol

Got it fixed up.



Should I be concerned with running the air until I get it filled up and recharged?

Last edited by seed60; 07-27-2008 at 02:24 PM.
Reply With Quote
  #24  
Old 07-27-2008
ranger024x4's Avatar
RF Veteran
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
even if you turn on the ac the compresser will not turn on if there isnt any refridgerant in the system.


sorry dude, but your gonna have to goto ford and buy that hose in order for you to have ac again.
Reply With Quote
  #25  
Old 07-27-2008
WowMike2001's Avatar
Member
 
Join Date: Oct 2007
Location: Stevenson, WA
Posts: 2,583
Thats why you need to come out this way... we are good at our bodylifts!



And really sucks for that part.. A/C isnt anything cheap, and you cant really fab a workaround very well =(
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help- front end sway/jump when slippery Bliss Suspension Tech 6 04-22-2014 07:05 AM
Black and Yellow, Black and Yellow Giraffe02 Snapshots 10 01-30-2011 06:33 PM
Post Your Bright Yellow Rangers!!!! Giraffe02 Snapshots 4 12-18-2010 08:21 PM
I drive a yellow submarine, a yellow submarine, a yellow submarine. $30 paint job t0x1k General Ford Ranger Discussion 49 10-28-2009 09:31 PM
Turns over and over and over before starting strictlystangs2 SOHC - 2.3L & 2.5L Lima Engines 7 11-21-2007 10:54 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:56 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.