4x4 Not Engaging | Shift Motor Repair - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-03-2015
Member
Thread Starter
 
Join Date: Mar 2013
Location: Meridian, ID
Posts: 3
4x4 Not Engaging | Shift Motor Repair

I almost got stranded out in the brush because I couldn't get my 4WD to engage in my 2004 Ranger 4.0L V6 man trans. I think it was the 10th try it finally decided to engage. My truck was losing its man card and I wasn't about to let that happen.

The Problem: 4wd not engaging.

Troubleshooting: Do the 4x4 lights in dash flash on and off during engine ignition? Do you hear clicks when you turn the 4x4 dial? If yes to both of these questions, proceed to solution. If not, you have a different problem.

The Solution: Pulled off shift motor off of transfer case by unscrewing 4 10mm bolts and unplugging electrical connection. Took to my work bench and removed the two (thicker) wires going to the motor (black tube about the size of half of a summer sausage). I hooked these wires up to a 12V battery I had laying around and tested the motor. It worked. Upon further research, I found out that the electronic components inside the gray plastic cap where the 5 wires enter were either dirty or oxidized. Problem is, there's no way to get in there and inspect. Unscrewing the three small torx screws won't get you to these wires. The only solution was to drill two small holes in the plastic cap, careful not to damage anything inside, and spray electrical cleaner inside. I let it dry, then mounted it back on transfer case to test and PROBLEM SOLVED. My ranger lives to see another day. I sealed the two holes with some caulk I had laying around. Hope this helps.

Last edited by Devin; 02-03-2015 at 11:11 AM.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
4x4 not engaging, and no "4x4" light rideac1 Drivetrain Tech 28 10-11-2017 07:23 PM
4x4 LOW NOT ENGAGING b0nkers General Ford Ranger Discussion 4 01-22-2015 01:32 AM
4WD not engaging hellsranger Drivetrain Tech 4 10-15-2010 10:06 AM
4x4 not engaging samacdon Drivetrain Tech 11 02-23-2010 02:10 PM
4x4 not engaging..any suggestions? GSU4x4 Drivetrain Tech 5 01-28-2007 06:23 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:10 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.