ABS engaging while braking - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-02-2012
Clinton's Avatar
Member
Thread Starter
iTrader: (19)
 
Join Date: Dec 2010
Location: PA.
Posts: 1,417
ABS engaging while braking

Yesterday my ABS system starting engaging during routine braking. While it did that the ABS light came on, but when I turn the truck off, the light goes off. Now today the ABS comes on every time I brake and the light stays on once again til I turn the truck off. Any ideas what could be causing this? Sensor maybe?

I do have to add, last year around this time, All CV's were replaced, Centric hubs added, ball joints, ABS sensors, rotors, brake pads. The rotors were upgraded to the 12" rotors being that I have the other holes on the superlift. I dont think (other than the hubs) these are playing a part of my problem but I am not sure.
Reply With Quote
  #2  
Old 07-02-2012
99offroadrngr's Avatar
TOYOTA
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
Its the sensor. My old truck used to do it all the time when it rained. I just sprayed them with wd40 and it lasted almost a year before it did it again. OR something could have come loose.

Last edited by 99offroadrngr; 07-02-2012 at 07:08 PM.
Reply With Quote
  #3  
Old 07-02-2012
Clinton's Avatar
Member
Thread Starter
iTrader: (19)
 
Join Date: Dec 2010
Location: PA.
Posts: 1,417
The thing is I put Centric hubs in, I believe those sensors can not be removed from the hub. I am hoping someone with experience with these Centric hubs can point me in the right direction
Reply With Quote
  #4  
Old 07-02-2012
99offroadrngr's Avatar
TOYOTA
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
the abs tone ring could of cracked throwing a code too but i don't know if the rangers will do that. ive never used centric hubs so idk
Reply With Quote
  #5  
Old 07-02-2012
Clinton's Avatar
Member
Thread Starter
iTrader: (19)
 
Join Date: Dec 2010
Location: PA.
Posts: 1,417
Yeah I heard about them there tone rings lol
Reply With Quote
  #6  
Old 07-03-2012
Clinton's Avatar
Member
Thread Starter
iTrader: (19)
 
Join Date: Dec 2010
Location: PA.
Posts: 1,417
Took it apart today, turns out the centric sensors CAN be removed. I swapped sensors, put it back together and so far so good except on hard left turns, while braking it feels like the ABS kicks in a little. Other than that, seems ok, gotta run it a little more and see what happens.
Reply With Quote
  #7  
Old 07-03-2012
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
then the hubs may be going bad...my ranger acted like that when my one hub was going out
Reply With Quote
  #8  
Old 07-03-2012
Clinton's Avatar
Member
Thread Starter
iTrader: (19)
 
Join Date: Dec 2010
Location: PA.
Posts: 1,417
Yeah I am thinking that. 1 year life span on a centric hub is BS. I always thought that was a high quality brand. I missed the warranty by one week!
Reply With Quote
  #9  
Old 07-03-2012
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
well dude you also have 35s lol
Reply With Quote
  #10  
Old 07-03-2012
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
x2 ^
Reply With Quote
  #11  
Old 07-06-2012
Clinton's Avatar
Member
Thread Starter
iTrader: (19)
 
Join Date: Dec 2010
Location: PA.
Posts: 1,417
The tires have nothing to do with it...I did research lol
Reply With Quote
  #12  
Old 07-08-2012
Clinton's Avatar
Member
Thread Starter
iTrader: (19)
 
Join Date: Dec 2010
Location: PA.
Posts: 1,417
After research and and consultations (Thank you Shane) I ordered up some Timken hubs and spindle nuts. I got hubs to fit an 07 ranger, it fits exact and the ABS sensor still connect well. Best part was the 07 hubs are 1/2 the price of the same ones listed for 01's.


I put the new hubs on today, about 3 hours of work with the cleanup!


I think this may solve my problem, test drive was good so I am keeping my fingers crossed!

I appreciate everyones help and input too!
Attached Thumbnails
ABS engaging while braking-61b2f901.jpg   ABS engaging while braking-bcb336af.jpg  
Reply With Quote
  #13  
Old 07-11-2012
fabioonachopper's Avatar
Member
 
Join Date: Feb 2008
Location: Ware,Ma
Posts: 96
pull fuse, forgetaboutit
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Loud click, like a clutch engaging while idling Ranger_Dude 2.9L & 3.0L V6 Tech 4 04-16-2011 06:45 PM
Squeaking while braking JDR48 General Technical & Electrical 10 11-06-2010 10:31 AM
ABS engaging on Dry Pavement? 01xltranger4x4 Drivetrain Tech 65 11-20-2008 03:30 PM
Truck pulls to the right while braking Mykhael General Ford Ranger Discussion 11 10-12-2008 04:25 PM
steering wheel 'shimmy' while braking (rocks back and forth) FMD General Ford Ranger Discussion 7 01-10-2007 09:51 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:10 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.