ABS light - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-03-2015
Fred@Imerj's Avatar
Member
Thread Starter
 
Join Date: May 2015
Location: Anthony, TX
Posts: 23
ABS light

Hey whats up everyone! I did a brake job not too long about on my ranger and maybe about 2 weeks after my ABS/TCS light popped up. It stays on until I park, shut the truck down and do what I need to do. A few minutes later or next day the light stays on, then after a few feet of driving it turn off. THEN about a few miles later it'll pop up or stay off for a few hours. Any ideas what it could be? I pulled the code for the right side ABS sensor. I didn't touch the sensor when I did the brake job.
Reply With Quote
  #2  
Old 12-03-2015
00GreenRanger's Avatar
Level III Supporter
 
Join Date: Nov 2011
Location: North Bend, WA
Posts: 1,343
Could just be a coincidence. I'd check the plug for the sensor and make sure that connection is good. It should be located up near the front bumper just off the frame. If that seems okay, replace the sensor. I don't believe they are too expensive.
Reply With Quote
  #3  
Old 12-04-2015
Fred@Imerj's Avatar
Member
Thread Starter
 
Join Date: May 2015
Location: Anthony, TX
Posts: 23
It crossed my mind that it could be a coincidence, but since I'm new to rangers I thought maybe it was a common problem. Yesterday the light flashed on, then off a few times. Then it stayed on.
Reply With Quote
  #4  
Old 12-06-2015
Fred@Imerj's Avatar
Member
Thread Starter
 
Join Date: May 2015
Location: Anthony, TX
Posts: 23
Update: I finally had time after the rotor/pad replacement to get in there and check the front ABS sensors that were giving me a headache. I realized I didn't hit the ABS rings on the rotors with brake cleaner prior to install. I jacked up the truck, located a decent sized opening on the back of spindle exposing the ring. I hit it with brake cleaner and removed the sensor while I was there. I cleaned the sensor with brake cleaner as well and reinstalled. I just came back from a 20-30 minute test drive and everything seems to be ok. ABS/TCS light are NOT on. Hopefully it stays this way.
Reply With Quote
  #5  
Old 04-05-2016
Fred@Imerj's Avatar
Member
Thread Starter
 
Join Date: May 2015
Location: Anthony, TX
Posts: 23
UPDATE: Well, the light did come back on so I bit the bullet and ordered a new ABS wheel sensor. Motorcraft part that wasn't too bad price wise. Fixed the problem, no issues since. Thanks everyone!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2000 Ranger 2 wheel abs or 4 wheel abs?? Please help NedoMedo Suspension Tech 6 02-23-2012 06:04 PM
4 wheel ABS or 2 wheel ABS? dirtybird819 Suspension Tech 7 02-27-2011 11:50 AM
2 wheel abs to 4 wheel abs ???? kenflash New Ideas 1 10-07-2010 06:01 AM
battery light ABS light dim light RangerSkippyRoo General Technical & Electrical 3 05-25-2009 11:25 AM
New ABS sensor, now ABS light. 01xltranger4x4 Drivetrain Tech 32 06-26-2007 06:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:11 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.