A/C Clicking On And Off? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-28-2008
Roach2004's Avatar
RF Veteran
Thread Starter
iTrader: (3)
 
Join Date: May 2005
Location: Houston, TX
Posts: 8,320
A/C Clicking On And Off?

Alright my A/C has not worked since atleast October (have not done anything about it cause it has not been hot out) Well when I switch it on the A/C turns on and off and does not get cold. The little plug onto of the A/C condenser I unplugged it and stuck a paper clip in the wire part plug and it stays on. Now do ya'll think that the part onto of the A/C condenser might just be messed up and I should replace it?

P.S.- That might be really confusing I can take a picture tomorrow if needs to be.

Thanks,
Roach
Reply With Quote
  #2  
Old 03-28-2008
oldman_d's Avatar
Member
 
Join Date: Mar 2008
Location: WA
Posts: 116
Have you tried to recharge it? Did that to mine and now it works great. Before I recharged, the condensor was constantly turning on and off, once it was recharged it would stay on non-stop.
Reply With Quote
  #3  
Old 03-28-2008
Roach2004's Avatar
RF Veteran
Thread Starter
iTrader: (3)
 
Join Date: May 2005
Location: Houston, TX
Posts: 8,320
Yea we tried recharging it.
Reply With Quote
  #4  
Old 03-28-2008
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
What is the air temps around you. Most Ac's have a sensor that tells them when it's below 40*.
Reply With Quote
  #5  
Old 03-28-2008
mossyoak03's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2006
Location: Virginia Beach, VA
Posts: 193
i would think it has to be your switch has a bad connection if you cut it on and its cuttin on and off. IMO.
Reply With Quote
  #6  
Old 03-28-2008
Jaykb's Avatar
Member
 
Join Date: Jan 2008
Location: Richlands, NC
Posts: 50
That switch is a low pressure switch and if you have recharged it then the switch is bad
Reply With Quote
  #7  
Old 03-28-2008
Roach2004's Avatar
RF Veteran
Thread Starter
iTrader: (3)
 
Join Date: May 2005
Location: Houston, TX
Posts: 8,320
Quote:
Originally Posted by rolsmojave3 View Post
What is the air temps around you. Most Ac's have a sensor that tells them when it's below 40*.
I live in south Texas where we have 60 degree winters! lol
Reply With Quote
  #8  
Old 03-28-2008
Roach2004's Avatar
RF Veteran
Thread Starter
iTrader: (3)
 
Join Date: May 2005
Location: Houston, TX
Posts: 8,320
Thanks guys I think I am just going to replace the switch.
Reply With Quote
  #9  
Old 03-28-2008
n3elz's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Kennett Square, PA
Posts: 10,620
The only problem is you'll let refrigerant out and air in. You should pull a vacuum on the system before recharging if you do that.

Did you do the recharge with a gauge in place? Or just ran a can in there? You don't know for sure you have the right pressure unless you gauged it.
Reply With Quote
  #10  
Old 03-28-2008
Roach2004's Avatar
RF Veteran
Thread Starter
iTrader: (3)
 
Join Date: May 2005
Location: Houston, TX
Posts: 8,320
Recharged with gauge in place. Thanks for the help John!
Reply With Quote
  #11  
Old 04-03-2008
Member
 
Join Date: Jun 2005
Location: Havertown,PA
Posts: 467
Hey Andy,not sure by your posts if the recharge fixed you or the switch?My truck has similar issue.When I turn on a/c,compressor clicks on and off but no cold air.It seems to go on/off alot faster than normal.So just wondering what got yours going?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Front end clicking and pulling hard to the right QC DSM ESiT General Technical & Electrical 0 08-23-2012 09:06 PM
EP-27 Flasher clicking with truck off and while driving. Sean04Ranger General Technical & Electrical 7 07-26-2012 11:06 AM
Changed timing belt and tensioner, now have a clicking/clacking sound. Rider99XX SOHC - 2.3L & 2.5L Lima Engines 7 02-27-2011 08:33 PM
A/C clicking and slow to cool Jazz921 4.0L OHV & SOHC V6 Tech 1 07-03-2009 10:06 AM
4x4 not working, and clicking sound? i_luv_strats General Technical & Electrical 6 10-26-2007 01:06 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:23 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.