a/c issues - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-20-2010
Member
Thread Starter
 
Join Date: Jan 2010
Location: king george virginia
Posts: 137
a/c issues

so at first my ac didnt work yall suggested checking the pressure and sure engh it didnt have any so i bought the 134a retrofit kit kit and changed it over and it worked great the first day now it keeps kickn the clutch on and off while driving and sometimes even idling i was wondering if yall any other ideas the pressure is rite at 45 and when the clutch is engaged it does make weird sound almost like a grinding noise but not exactly like a grind im not sure how to describe it but anyways its really annoying going down the road feeling it when it kicks on and off...i know at full throttle it should cut off but it does constantly even when i am cruising down the road at normal speed...i have a vacuum gauge installed and when the ac is off it runs between 8 and 15 hg at highway speeds just depends on if im passing people or not and when the ac is on its between 5 and 12 hg...to me that is normal so im not sure wats going on and why it keeps kickin the ac clutch off any help would be apprciated
Reply With Quote
  #2  
Old 08-20-2010
03DualSport's Avatar
Member
 
Join Date: Jul 2005
Location: Wimberley, Tx
Posts: 260
probably undercharged. also if you didn't have any freon in the first place you have a leak.
Reply With Quote
  #3  
Old 08-22-2010
Member
Thread Starter
 
Join Date: Jan 2010
Location: king george virginia
Posts: 137
cant be undercharged at least according to the gauge its at max pressure for the system and if it had a leak then the pressure would drop and its been 45 since i put it in 2 weeks ago
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Gauge issues/heating issues/high oil pressure Fw87 General Ford Ranger Discussion 2 04-26-2015 12:08 AM
Idle Air Sensor and Shift issues JaxRanger 2.9L & 3.0L V6 Tech 0 09-24-2008 08:56 AM
i need opinions Wheel size issues...4.0 edge afi_pilot85 Wheels & Tires Semi-Tech 10 04-05-2005 02:30 AM
Camber Issues eXtremePC Wheels & Tires Semi-Tech 6 11-26-2004 12:37 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:37 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.