Check Engine Flashing - Ongoing Issue :( - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 06-22-2009
Prerunner-Ranger's Avatar
Level I Supporter
Thread Starter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
Can anyone else second tonyz on passenger side cylinder 6?
Reply With Quote
  #27  
Old 06-22-2009
Prerunner-Ranger's Avatar
Level I Supporter
Thread Starter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
Reply With Quote
  #28  
Old 06-22-2009
Member
 
Join Date: May 2009
Location: scranton, pa
Posts: 28
yes no 6 would be against firewall according to the pic
Reply With Quote
  #29  
Old 06-22-2009
Member
 
Join Date: May 2009
Location: scranton, pa
Posts: 28
drivers side
Reply With Quote
  #30  
Old 06-23-2009
Prerunner-Ranger's Avatar
Level I Supporter
Thread Starter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
That's the one I changed.
Reply With Quote
  #31  
Old 06-23-2009
Member
 
Join Date: May 2009
Location: scranton, pa
Posts: 28
well i probably would change the plug wire before the coil pack if you only switched the plug out on the n0. 6 cyl it could be a bad wire. when you switched plug out did you put a new one in or just swap 6 to 5
Reply With Quote
  #32  
Old 06-23-2009
Member
 
Join Date: May 2009
Location: scranton, pa
Posts: 28
is your engine running rough at all R.P.M.S or is it just at idle that your light comes on if only at idle it could be a bad throttle position sensor if your rpms get to low that could send a false signal to your ecm because your engine wants to stall
Reply With Quote
  #33  
Old 06-23-2009
Member
iTrader: (6)
 
Join Date: Mar 2008
Location: San Jose, CA
Posts: 822
Try sea-foaming it. Get some electrical cleaner and clean your MAF maybe check your Filter too. And check the timing on it. Check the fuel filter too. Those are all the things I would check on it first. Pretty easy and cheap things to do.
Reply With Quote
  #34  
Old 06-23-2009
Member
 
Join Date: Feb 2009
Location: Las Vegas, NV
Posts: 161
I just changed the plugs in my 01' 3.0L. Wires have numbers on them as such if your looking into the engine bay from the front of the truck:


Passenger __ Driver
3 __________6
2 __________5
1 __________4
Reply With Quote
  #35  
Old 06-23-2009
FullThrottle02's Avatar
Member
iTrader: (3)
 
Join Date: Apr 2008
Location: McHenry,IL
Posts: 586
It could be a valve issue, but if it only does it sometimes probably not. To check the injectors you need a Noid Light or a test light should work. To do unplug the injector you want to check with light attached to harness side of connector. and watch it flash, which would indicate it is firing. You could possibly have a bad wire to the injector. You could trace it back to the pcm and check for continunity. The injectors also should have 12v at the connector. You could check for this also. I hope this helps.
Reply With Quote
  #36  
Old 06-23-2009
Prerunner-Ranger's Avatar
Level I Supporter
Thread Starter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
Quote:
Originally Posted by tonyz View Post
well i probably would change the plug wire before the coil pack if you only switched the plug out on the n0. 6 cyl it could be a bad wire. when you switched plug out did you put a new one in or just swap 6 to 5
All brand new wires. The one in 6 was brand new so I swapped it with 5. Now it won't hold a solid check engine light, just flash at idle.

Quote:
Originally Posted by tonyz View Post
is your engine running rough at all R.P.M.S or is it just at idle that your light comes on if only at idle it could be a bad throttle position sensor if your rpms get to low that could send a false signal to your ecm because your engine wants to stall
That is quite a possibility. What's the best way to check the TPS?

Quote:
Originally Posted by FRXLT View Post
Try sea-foaming it. Get some electrical cleaner and clean your MAF maybe check your Filter too. And check the timing on it. Check the fuel filter too. Those are all the things I would check on it first. Pretty easy and cheap things to do.
I'll do a seafoam on it today, clean the maf, and air filter. How would I check the timing? Fuel filter is brand new.

Quote:
Originally Posted by FullThrottle02 View Post
It could be a valve issue, but if it only does it sometimes probably not. To check the injectors you need a Noid Light or a test light should work. To do unplug the injector you want to check with light attached to harness side of connector. and watch it flash, which would indicate it is firing. You could possibly have a bad wire to the injector. You could trace it back to the pcm and check for continunity. The injectors also should have 12v at the connector. You could check for this also. I hope this helps.
I'll look into this. Thanks.
Reply With Quote
  #37  
Old 06-23-2009
Prerunner-Ranger's Avatar
Level I Supporter
Thread Starter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
Just Seafoamed it, Cleaned MAF, and TB... we'll see what happens.
Reply With Quote
  #38  
Old 06-26-2009
Prerunner-Ranger's Avatar
Level I Supporter
Thread Starter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
Welp last night check engine came back and flashed a bit. As soon as I started driving again it went away.

sigh.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
!!Flashing check engine light!!!!!????? fletch12518 4.0L OHV & SOHC V6 Tech 80 01-06-2013 07:15 PM
Ongoing cooling system issues korey89 2.9L & 3.0L V6 Tech 5 03-01-2010 07:55 PM
check engine light flashing and truck losing power..help? Sonic04Edge 2.9L & 3.0L V6 Tech 5 08-17-2008 07:41 PM
1997 Ranger 3.0 Check Engine light flashing hardrock30096 General Ford Ranger Discussion 0 03-28-2008 03:18 PM
ongoing heater valve leaking problem shuckyd General Ford Ranger Discussion 9 08-14-2006 08:20 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:40 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.