Code 543 retrieved....Fuel Pump Secondary Circuit Fault. - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-10-2006
Jeremy102579's Avatar
Member
Thread Starter
 
Join Date: Jun 2006
Location: North Tonawanda, NY
Posts: 431
Code 543 retrieved....Fuel Pump Secondary Circuit Fault.

i recieved my obd-1 code scanner in the mail today and hooked it up to my 94 ranger.

for the last month, my CEL has been coming on for a minute, then goes off for a minute, then comes on again and repeats every couple minutes.

I got a code of 543.......

Code Reader Manual says.....Fuel Pump Secondary Circuit Fault.
Haynes manual says.......Fuel Pump Circuit Open; Battery to PCM.

Where and how do i start in correcting this known problem?

thanks

jr
Reply With Quote
  #2  
Old 11-10-2006
ahoyhoy239's Avatar
Member
 
Join Date: Sep 2006
Location: Miami, FL
Posts: 33
i really dont have a legitamite answer, but ill venture to guess that by what the haynes manual says, maybe a fuse is blown for the fuel pump or the pcm(powertrain control module?), so first thing i would do is check the fuse box or the haynes manual for fuel pump fixes?

kinda obvious i know but maybe it helps
Reply With Quote
  #3  
Old 11-10-2006
Jeremy102579's Avatar
Member
Thread Starter
 
Join Date: Jun 2006
Location: North Tonawanda, NY
Posts: 431
all the fuses look good, thanks.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Code P0460-Fuel Level Sensor A Circuit RangerWill76 General Technical & Electrical 0 08-21-2015 05:16 PM
$125 Fuel Pump vs $300 Fuel Pump? Which to get? TheRealestWhiteBoy General Technical & Electrical 12 01-19-2013 08:05 PM
open circuit to fuel pump coachjoe General Technical & Electrical 2 03-11-2011 11:51 AM
open circuit to fuel pump won't run coachjoe 4.0L OHV & SOHC V6 Tech 7 03-09-2011 09:54 AM
code 176 retrieved......HEGO (HO2S) SENSOR FAULT/RICH Jeremy102579 General Technical & Electrical 1 11-12-2006 01:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:27 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.