A couple of issues on my Explorer - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-14-2007
pacodiablo's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Charlotte, NC
Posts: 1,126
A couple of issues on my Explorer

I just bought a 1995 Explorer Sport and need a little help diagnosing some strange issues.

1. The dome lights decided to stay on today. This occured after a rain storm, but I can't say for sure if that caused the problem. The door ajar light does NOT come on when the dome lights stay on, it goes off like it is supposed to. For now, I have taken the bulbs out, but I'd like to find a permanent fix.

2. Sometimes when I use the left turn signal, the control stalk just makes a buzzing noise rather than turning the signal on. It is not a big deal, but a little annoying. I think the control stalk is kind of dying anyway since sometimes the wipers and washer are slow to respond sometimes.
Reply With Quote
  #2  
Old 09-14-2007
gatorblue92's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Delaware
Posts: 8,238
try spraying wd-40 in the door latches to see if that fixes the dome light issue
Reply With Quote
  #3  
Old 09-14-2007
pacodiablo's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Charlotte, NC
Posts: 1,126
The problem is fixed, not WD-40 required. My dumbass accidently turned the dimmer switch all the way up when I was cleaning the inside. So problem # 1 is solved, lol.
Reply With Quote
  #4  
Old 09-14-2007
malydeen's Avatar
Member
iTrader: (12)
 
Join Date: Jul 2007
Location: Minneapolis, MN
Posts: 632
Go buy a new flasher bulb (i think thats what its called, its a little silver can with 3 blades comming out the back, its next to the fuses at walmart). To put it in...good question. I don't know where they put them on the ranger. Usually you have to remove the panels under the steering wheel to get to em'.

I had the same problem on my corsica, and thats how I fixed it.

EDIT: I just noticed you said the wipers were dying too. I dont know about that but the flasher bulb is like $2. Some thing to try before you go into more in depth stuff.
Reply With Quote
  #5  
Old 09-19-2007
pacodiablo's Avatar
Member
Thread Starter
 
Join Date: Jun 2004
Location: Charlotte, NC
Posts: 1,126
Good diagnosis...it was the flasher. No problems now. I didn't have to remove any panels, but it was kind of a pain to reach. It is directly under the steering column and is bright yellow.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Gauge issues/heating issues/high oil pressure Fw87 General Ford Ranger Discussion 2 04-26-2015 12:08 AM
Couple of issues axle27 2.9L & 3.0L V6 Tech 3 08-12-2013 08:16 AM
new guy with a couple electrical problems and maybe a mechanical issue and a couple bonzo 1 General Technical & Electrical 5 12-27-2009 06:09 PM
A couple mods, a couple pics RangerJustin Snapshots 31 05-01-2008 11:41 AM
couple issues in 97 xtra cab bgrd351 Interior Semi-Tech 8 10-03-2007 07:29 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:26 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.