Dash function's A real head scratcher..... - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-22-2009
maxdog1's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: Howell MI
Posts: 5
Icon5 Dash function's A real head scratcher.....

1998 2.5 5spd. 2wd (my highway special) Here is the story. speedo stoped working above 40 anything less it still worked, odometer worked at all speed's, read posts and decided to swap cluster out w/ junkyard one with tach, now everything works, but the speedo/odometer. I don't even have to forty now. plug in the old unit and i still have speedo???? Am changing the VSS on the axle tomorow, and inspecting wiring.
Reply With Quote
  #2  
Old 07-23-2009
WowMike2001's Avatar
Member
 
Join Date: Oct 2007
Location: Stevenson, WA
Posts: 2,583
I had this issue in my moms 98' galaxy - above 40 the speedo woudl bottom out and drop.. really sucked on teh highway - I think it was a grounding fault behind the speedo - maybe pull it out and inspect wires, make sure nothign is crossed there
Reply With Quote
  #3  
Old 07-23-2009
maxdog1's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: Howell MI
Posts: 5
ok i checked i don't see any crossed wires
Reply With Quote
  #4  
Old 07-23-2009
maxdog1's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: Howell MI
Posts: 5
had to go back to junkyard and return the cluster out of the 99 and get one off a 98 it worked first try!!!
Reply With Quote
  #5  
Old 07-23-2009
SVT01RANGER's Avatar
Member
iTrader: (2)
 
Join Date: Jun 2004
Location: West Eugene, OR
Posts: 3,634
there must have been a problem with the cluster, they should all be interchangeable from 98-2003
Reply With Quote
  #6  
Old 07-24-2009
maxdog1's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: Howell MI
Posts: 5
well it works so i'm happy the only problem is this nice crack on the lens, am trying to find a good deal on a new lens now
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Truck 145 miles from home! HEAD SCRATCHER Turbofox08 SOHC - 2.3L & 2.5L Lima Engines 20 01-07-2014 02:52 PM
iTrader function not working properly, or am I just a noob? Fx4wannabe01 Ranger-Forums Office 12 06-05-2009 01:58 PM
Multi-function switch woes heaton84 General Technical & Electrical 14 03-27-2008 08:17 PM
mult-function switch repair? falcon61 General Technical & Electrical 4 01-02-2008 06:39 PM
No pause function on the CD6? FireRanger Audio & Video Tech 12 07-04-2006 09:47 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:14 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.