electrical help - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-18-2010
Member
Thread Starter
 
Join Date: Jun 2010
Location: jacksonville,florida
Posts: 32
electrical help

when i bought my truck it had a electrical problem in the fuse box nothing really worked in the truck now thats fixed every thing works fine the other day i was charging my ac and used it for the first time and when i turned the truck off i came back about an hour later and it wouldnt run fuel pump went out would that have somthing to do with it or was it just time for it to go and happened to happen then?
Reply With Quote
  #2  
Old 06-18-2010
Member
 
Join Date: Mar 2007
Location: Upstate,NY
Posts: 2,598
My first guess would be fuel pump relay or its contacts where it plugs in.
Second would be the enertia (sp) switch in the passenger side footwell.
Reply With Quote
  #3  
Old 06-18-2010
Member
Thread Starter
 
Join Date: Jun 2010
Location: jacksonville,florida
Posts: 32
it was the fuse box in the cab that i had problems with but the relays were fine under the hood i did the whole wiggle test to the harnes after i fixed it and it passed with flying colors i was just wondering if the ac controls at all short out the fuel pump or the pump just went out at the time i was workin on my ac?
Reply With Quote
  #4  
Old 06-19-2010
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
Should be totally separate.
Reply With Quote
  #5  
Old 06-19-2010
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
You may have to take off the bed to test the fuel pimp for power if everything else checks out
Reply With Quote
  #6  
Old 06-20-2010
Member
Thread Starter
 
Join Date: Jun 2010
Location: jacksonville,florida
Posts: 32
the fuel pump was getting enough power and i fixed the ac today and gave it a run and all is fine so far.
Reply With Quote
  #7  
Old 09-21-2010
Member
 
Join Date: Sep 2010
Location: willingboro
Posts: 18
fuel pump voltage

which four wires do i check for voltage? with reguards to the plug to the pump. ylw/wht pinlk/blk blk and one other wire. i get 12v at yellow/hite as + and black as - looking inside pump i see pnk/black goes to pump?? cant seem to be able to get voltage on that wire. inertia swich checks out ok....pump relay has been switched.

Last edited by bigred08046; 09-26-2010 at 08:16 PM.
Reply With Quote
  #8  
Old 09-22-2010
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
^Huh?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help from the electrical gurus. -DRLs- winks General Technical & Electrical 37 09-29-2016 08:24 PM
need help with e-fan....calling all electrical guru's.. TippnOver General Technical & Electrical 12 11-10-2005 02:52 PM
Need help with Wiring... Electrical.. FoMoCoFiddy General Technical & Electrical 10 10-27-2005 05:22 PM
A WIERD electrical problem... HELP! EdGe_wannabe General Technical & Electrical 5 10-01-2005 03:15 AM
Electrical problem/question... HELP! Bob, anybody! rngprerunner General Technical & Electrical 11 09-25-2005 07:57 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:14 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.