Electrical problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-22-2010
Member
Thread Starter
 
Join Date: Mar 2010
Location: Lindale Ga
Posts: 3
Post Electrical problem

Hi everone.Need to find out why my dome light will not come on when i open the door nor when i push the light switch to the top.any commets are welcomed
Reply With Quote
  #2  
Old 03-22-2010
98rangerxlt's Avatar
Member
 
Join Date: Mar 2009
Location: Bakersfield, CA
Posts: 725
Burned out bulbs maybe?
Reply With Quote
  #3  
Old 03-22-2010
stangdroptop351's Avatar
Member
 
Join Date: Feb 2010
Location: Scottdale,PA
Posts: 511
blown fuse
Reply With Quote
  #4  
Old 03-22-2010
j99ranger4x4's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: Delaware, OH
Posts: 1,381
What fuse would It be.
Reply With Quote
  #5  
Old 03-22-2010
Member
Thread Starter
 
Join Date: Mar 2010
Location: Lindale Ga
Posts: 3
checked all fuse i think they are ok cant get the cover off the dome
Reply With Quote
  #6  
Old 03-22-2010
j99ranger4x4's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: Delaware, OH
Posts: 1,381
lots of electrical problems

Ok guys so I just bought a 99 and I know it has several problems. It was wrecked at some point and was only halfway repaired. I I have airbag light on which it is missing a sensor. But my other problems are the dome light doesn't work. Bulbs look ok. Its missing the cover but still should work. Then I believe the steering column was changed cuz it has power windows and locks so it should have cruise right? Also the horn doesn't work and the flashers are delayed. Any help would be appreciated.
Reply With Quote
  #7  
Old 03-22-2010
j99ranger4x4's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: Delaware, OH
Posts: 1,381
Oops meant to he a new post. Doing this on my phone.
Reply With Quote
  #8  
Old 03-22-2010
Member
Thread Starter
 
Join Date: Mar 2010
Location: Lindale Ga
Posts: 3
hey guys also why doent my 4 wheel lights on the dash come on when i go to 4 high
Reply With Quote
  #9  
Old 03-22-2010
j99ranger4x4's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: Delaware, OH
Posts: 1,381
Probably just a burnt out bulb.
Reply With Quote
  #10  
Old 03-22-2010
Toreador4x4's Avatar
Member
iTrader: (6)
 
Join Date: Apr 2007
Location: Livonia, MI
Posts: 3,958
check the fuse for the GEM module...it controls 4x4 and interior light
Reply With Quote
  #11  
Old 03-23-2010
acemavrick's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2009
Location: ky
Posts: 663
i have a 92 supercab where is the fuse for the dome/3rd brake light??
Reply With Quote
  #12  
Old 03-23-2010
RLong31's Avatar
The Ban Hammer
iTrader: (5)
 
Join Date: Jul 2009
Location: Monrovia, IN
Posts: 2,629
Owner's manual... always check your owner's manual. Believe it or not, it contains useful information.
Reply With Quote
  #13  
Old 03-23-2010
acemavrick's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2009
Location: ky
Posts: 663
haha i bought the truck and no manual... i need to take out this fuse! its draining my batt....
Reply With Quote
  #14  
Old 03-24-2010
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
What's draining your battery?
Reply With Quote
  #15  
Old 03-24-2010
smcasey88's Avatar
Level II Supporter
 
Join Date: Sep 2009
Location: Reno, Nv
Posts: 317
Quote:
Originally Posted by j99ranger4x4 View Post
Ok guys so I just bought a 99 and I know it has several problems. It was wrecked at some point and was only halfway repaired. I I have airbag light on which it is missing a sensor. But my other problems are the dome light doesn't work. Bulbs look ok. Its missing the cover but still should work. Then I believe the steering column was changed cuz it has power windows and locks so it should have cruise right? Also the horn doesn't work and the flashers are delayed. Any help would be appreciated.
Are you sure the bulbs are ok? if you have a test light or something test the domelight and see if you have power there. But double check on the fuses again too, Im not sure about a "99" but the fuse on my "06" that controls the interior lights also goes to the horn as well. And no, just because you have power windows and locks doesnt mean you should have cruise too, mine has power locks and windows, mirrors etc..but no cruise.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Slight Electrical Problem w. Truck. EdGe_wannabe General Technical & Electrical 9 12-21-2006 11:10 AM
Electrical problem? Hefavitzen 2.3L & 2.5L I4 Tech 5 08-01-2006 02:56 PM
A WIERD electrical problem... HELP! EdGe_wannabe General Technical & Electrical 5 10-01-2005 03:15 AM
Electrical problem/question... HELP! Bob, anybody! rngprerunner General Technical & Electrical 11 09-25-2005 07:57 PM
Problem with electrical ranger024x4 4.0L OHV & SOHC V6 Tech 7 10-12-2004 04:30 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:26 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.