Engine died? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-26-2010
Ardy's Avatar
Member
Thread Starter
 
Join Date: Aug 2010
Location: Windsor NS
Posts: 276
Engine died?

Driving my 89 ranger down the road today she stalled once out of nowhere just sputtered then died. Weirded out I just decided to re-crank her, nothing. After about 3-4 minutes I cranked again and started fine. Strange enough, so I went to turn her around and bring her home before any more damage. About 10 minutes later driving down a straight-a-way she started sputtering again and out of instinct threw in the clutch and bam, dead. She hasn't started since. Had to have her towed home.

What should I be looking at? I'm guessing it's fuel-based either the pump, ****ty filter, or maybe something wrong with injection system?
Reply With Quote
  #2  
Old 11-27-2010
Ardy's Avatar
Member
Thread Starter
 
Join Date: Aug 2010
Location: Windsor NS
Posts: 276
Okay, just out of curiosity I pulled a spark plug. Look fairly normal but smelled like unburned gas. What would you guys suggest? =\

How would I test if I'm getting spark?

Sorry for my stupidity!

Last edited by Ardy; 11-27-2010 at 12:20 PM.
Reply With Quote
  #3  
Old 11-27-2010
87xlt's Avatar
Member
 
Join Date: Jun 2008
Location: In my truck!
Posts: 875
Take a screwdriver and put it in the end of a sparkplug wire hold the screwdriver close to something metal (no fuel system components) have a helper crank the truck and see if you have a spark jumping from the screwdriver. I have a feeling your coil has went bad on you. Good luck!
Reply With Quote
  #4  
Old 11-27-2010
Ardy's Avatar
Member
Thread Starter
 
Join Date: Aug 2010
Location: Windsor NS
Posts: 276
Sounds a little scary! :P Will give it a go and post results.
Reply With Quote
  #5  
Old 12-03-2010
Ardy's Avatar
Member
Thread Starter
 
Join Date: Aug 2010
Location: Windsor NS
Posts: 276
I believe it's the distributor, is there any fixes for the distributor besides replacing?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
engine died now has trouble cranking littlered 2.9L & 3.0L V6 Tech 4 05-29-2015 11:28 PM
engine died bbaughman2008 DOHC - 2.3L Duratec / Mazda L Engines 5 07-13-2013 11:30 PM
Engine died and quit turning over, thoughts? luciow_95 2.9L & 3.0L V6 Tech 5 05-09-2013 08:12 PM
engine died on me the other day.. STLRanger General Ford Ranger Discussion 7 03-31-2012 08:52 PM
2000 2.5 Manual Died on Freeway elborba SOHC - 2.3L & 2.5L Lima Engines 9 04-12-2011 07:57 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:45 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.