Ranger-Forums - The Ultimate Ford Ranger Resource

Ranger-Forums - The Ultimate Ford Ranger Resource (https://www.ranger-forums.com/)
-   General Technical & Electrical (https://www.ranger-forums.com/general-technical-electrical-18/)
-   -   Flashers work, signals don't (https://www.ranger-forums.com/general-technical-electrical-18/flashers-work-signals-dont-149250/)

RocketRod 10-02-2016 12:00 PM

Flashers work, signals don't
 
1st post, sorry haven't searched much for an answer. 2005 Ranger FX4 II. Just got it and have a signal issue. They worked for 2 days, today nothing. 4 way flashers work. Not sure if those are on another relay or not. I have had the rear lights off trying to fix the back up lights ( found some previous owner has no idea about removing a simple connector, who broke it, replacement on order). Anyway, signals don't work. I also have an issue that I am looking into also with the ABS & Brake lights on. I used the park brake to hold the truck in reverse while checking lights. Brake light plunger seems to work fine. Thanks for your help in advance. Off to work and then will check responses.

RocketRod 10-02-2016 08:22 PM

So according to the Haynes, there are 2 flashers to the right of the column. Nope, only one. Not anything like the one I picked up. Now to find a map of the fuse box's.

RocketRod 10-02-2016 09:02 PM

Fixed. Fuse #22 in passenger box. Also cured the ABS & Park brake light, which is weird.

eaglet2 10-03-2016 02:12 PM

fuse 2.20
 
fuse 2.20 feeds flasher, abs VPWR what ever that is and park brake switch on R 2005


All times are GMT -6. The time now is 01:29 PM.