Help!!!!!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-10-2006
Member
Thread Starter
 
Join Date: May 2006
Location: spring lake, nc
Posts: 55
Help!!!!!!!

so no **** ive driven my fx4 lvl2 threw some really sticky **** ive even pulled an f250 who was stuck up to the axles but the other day i went threw a dinky *** mud puddle and it dies now i cant start it tried pull starting it nothing i pulled the plugs still wont turn over please ne help is appreciated thanx
Reply With Quote
  #2  
Old 11-10-2006
NicksterSVT's Avatar
Member
 
Join Date: Apr 2005
Location: NC
Posts: 1,955
its broke.
Reply With Quote
  #3  
Old 11-10-2006
jorlee's Avatar
Member
 
Join Date: Jul 2005
Location: SW North Dakota
Posts: 119
Did you pull the plugs before or after attempting to start it?

When you pull started it, did it turn the motor over?
Reply With Quote
  #4  
Old 11-10-2006
04 EDGE
Unregistered User
 
Posts: n/a
wont turn over? is the starter cranking?
Reply With Quote
  #5  
Old 11-11-2006
Member
Thread Starter
 
Join Date: May 2006
Location: spring lake, nc
Posts: 55
well thanx i know its broke the plugs were in the first time we tried to pull start it and as far as the the starter i here the selinoid hitting and a high pitch electrical sound but i dont here the starter
Reply With Quote
  #6  
Old 11-11-2006
RockysFord's Avatar
Member
 
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
Put a breaker bar / socked on the crank pulled and try turning the motor over by hand....see if its locked up....

If the sylonoid is not engaging the starter and cranking then its more than likely hydro locked

Like L2EN .....how much water was in the mud hole? check your intake box and see if there is water in there / filter is wet....

Rocky
Reply With Quote
  #7  
Old 11-11-2006
jorlee's Avatar
Member
 
Join Date: Jul 2005
Location: SW North Dakota
Posts: 119
Starter seems to be working fine. High pitches noise would be it straining to turn the motor over. Appears you have some parts that are broke in side the motor that isn't allowing it to turn over freely.
Reply With Quote
  #8  
Old 11-11-2006
KARPE's Avatar
Member
 
Join Date: Apr 2005
Location: Valrico, Fl 33594
Posts: 4,748
Quote:
Originally Posted by NicksterSVT
its broke.
hahah

you got the same problem as Travis (L2en) you're ****'s seized up like a ****

Last edited by KARPE; 11-11-2006 at 12:03 PM.
Reply With Quote
  #9  
Old 11-11-2006
Member
Thread Starter
 
Join Date: May 2006
Location: spring lake, nc
Posts: 55
ok anyone know where i can find connecting rods if its hydro locked then more then likely i bent a rod and thats whats not allowing the turn over
Reply With Quote
  #10  
Old 11-14-2006
l2en's Avatar
Member
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
I turned mine over to insurance

I'm still waiting to get the new motor, clutch, and whatever else....
Reply With Quote
  #11  
Old 11-14-2006
Morph's Avatar
Member
 
Join Date: Jul 2005
Location: Grand Rapids, MI
Posts: 979
Quote:
Originally Posted by l2en
I turned mine over to insurance

I'm still waiting to get the new motor, clutch, and whatever else....
Sorry to hi-jack, but Ins. is convering it? Awsome.
Reply With Quote
  #12  
Old 11-14-2006
l2en's Avatar
Member
 
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
Quote:
Originally Posted by Morph
Sorry to hi-jack, but Ins. is convering it? Awsome.
Oh yeah =]

Since the adjuster took so long to look at the truck.....I told them that the clutch was ruined due to the lack of power and that the master cylinder went as well =]

Serves em right for *fogive the pun* burning me on my last truck =]
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HELP !HELP! HELP! 3.0 V6 Driving me insane Hunter74 2.9L & 3.0L V6 Tech 21 03-06-2016 12:08 PM
Help Help Help!!!!!!! EdgeGOBoom 2.9L & 3.0L V6 Tech 6 09-16-2007 01:01 AM
Help Help Help Gear Indicator Stuck BananaEdge General Technical & Electrical 5 06-16-2005 12:05 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:57 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.