hesitation & bucking - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-13-2008
Rob99's Avatar
Member
Thread Starter
 
Join Date: Jan 2005
Location: Nutley, NJ
Posts: 174
hesitation & bucking

This problem just started only happens between 35-40mph it's noticable enough to to feel although no backfiring or popping ,all other speeds are fine and revving in nuetral dosn't replicate it.
fuel filter was changed a few thousand miles ago
as were plugs,wires, thermo new air filter, no codes i checked with my Innova scanner
Startup idle goes high when cold and sometimes takes long to come down.
4.0SOHC approx 58,000miles hope i gave enough info to try and diagnose
TIA for any ideas/help. Rob
Reply With Quote
  #2  
Old 10-14-2008
Crunchy's Avatar
Member
 
Join Date: Oct 2007
Location: Hull, Quebec
Posts: 486
Does it feel like someone hit your from behind? A tranny flush fixed it for me, my fluid was on its way out.
Reply With Quote
  #3  
Old 10-14-2008
Rob99's Avatar
Member
Thread Starter
 
Join Date: Jan 2005
Location: Nutley, NJ
Posts: 174
yea it kinda feels like that, i recently(at 50,000) had the tranny flushed & new filterso im not thinking it's the tranny.
i did mess around with it today and with the hood up and moving the accel cable at the throtle body i can hear a slight miss i sprayed TB cleaner and put in some techron gas additive, and see what happens.
Reply With Quote
  #4  
Old 10-15-2008
wydopnthrtl's Avatar
Member
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
I'd clean the MAF sensor and disconnect the battery for 10 minutes.
It's cheap and would at least rule out a simple thing.


If that didn't change things.. I'd go looking for a vacuum leak.

Rich
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
4.0 skip/misfire/bucking OVERtheEDGE 4.0L OHV & SOHC V6 Tech 49 02-16-2009 08:31 AM
bucking, kicking, rough idle sams dad 4.0L OHV & SOHC V6 Tech 17 10-10-2007 07:11 PM
Bucking 2.5L ranger1998xlt SOHC - 2.3L & 2.5L Lima Engines 1 02-06-2007 12:35 PM
Running really bad-Stuttering-Bucking bmxrider379 4.0L OHV & SOHC V6 Tech 4 09-11-2006 07:04 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:50 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.