HID lights on working on one side - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-30-2010
Member
Thread Starter
 
Join Date: Dec 2010
Location: shep, ky
Posts: 6
Icon4 HID lights on working on one side

I bought ddm tuning apexcone hid 35w 6000k hi/low. I drove it all the way to work with them working. I turned them off and then back on to show a co worker and then just the left is working. It there a fuse on each ballast?
Reply With Quote
  #2  
Old 12-30-2010
ranger024x4's Avatar
RF Veteran
iTrader: (6)
 
Join Date: Aug 2004
Location: nova
Posts: 5,061
no, but you should have a fuse for each headlight in the fuse panal.
Reply With Quote
  #3  
Old 12-30-2010
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
My year rangers only had one fuse for the headlights.
Reply With Quote
  #4  
Old 12-30-2010
Member
Thread Starter
 
Join Date: Dec 2010
Location: shep, ky
Posts: 6
Well I figured out, I had a bad ground to the ballast on that side. Thanks for help
Reply With Quote
  #5  
Old 12-30-2010
Ford04Ranger4.0's Avatar
Member
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
how do u like those hids? I have the DDM 35w hi/low and they suck
Reply With Quote
  #6  
Old 12-30-2010
Member
Thread Starter
 
Join Date: Dec 2010
Location: shep, ky
Posts: 6
Well I only have had them on there for 2 days now, but so far I like them. They are diffently brighter than my stock halogens. I haven't heard good things about the slim ballast hid. Mine are the regular ballast apexcone raptor 9007 hi/low 35w 6000k
Reply With Quote
  #7  
Old 12-31-2010
Ford04Ranger4.0's Avatar
Member
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Do you have the site were you bought them from?
Reply With Quote
  #8  
Old 12-31-2010
Member
Thread Starter
 
Join Date: Dec 2010
Location: shep, ky
Posts: 6
ddmtuning.com
Reply With Quote
  #9  
Old 02-28-2011
Member
 
Join Date: Feb 2011
Location: UK
Posts: 2
I have just bought a 2009 Thunder Double cab with HiD conversion. lights work fine (apart from r/h side just stopped working, but haven't had time to check fuses yet).
Dash high beam indicator does not work at all though!

Is this normal for Hid's, is there a fix or is it a fault? I have no idea what system has been installed.

This is my first experience with this HiD's so any expert views on this are greatly appreciated
Reply With Quote
  #10  
Old 02-28-2011
whisky's Avatar
Member
 
Join Date: Apr 2009
Location: Lincoln,Nebraska
Posts: 265
Quote:
Originally Posted by Ford04Ranger4.0 View Post
how do u like those hids? I have the DDM 35w hi/low and they suck
Same here the low is ok but the highs suck
Reply With Quote
  #11  
Old 03-02-2011
Member
 
Join Date: Feb 2011
Location: UK
Posts: 2
Both working now so must be intermittent connection/earth ?

Aparently the dash High Beam light does not function with HiD's due to resistance changes, dont know if there's a fix?

Low beam is bright but a little "woolley" at the top. Hi beam is like looking through a letter box, very wide & thin but ok i guess. Probably needs projector lenses to focus beam properly. Bought the car with Hid's already fitted so can't compare to the std Ranger halogens.
Reply With Quote
  #12  
Old 03-04-2011
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
Quote:
Originally Posted by whisky View Post
Same here the low is ok but the highs suck
flip the pos pins so lows are the halogen bulb, and the high is the HID. unless you bought them for the look of hids on your truck, then your just gay.
Reply With Quote
  #13  
Old 03-04-2011
whisky's Avatar
Member
 
Join Date: Apr 2009
Location: Lincoln,Nebraska
Posts: 265
My dash high beam lite goes on when I turn them on
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
All warning lights on -- signal lights stopped working Rob91 General Technical & Electrical 1 02-04-2012 05:27 PM
Installed HID lights in headlamps but now my fog lights will not work BmillerEdge General Technical & Electrical 1 12-29-2010 10:37 AM
For Sale: HID Bulbs, HID Ballast, Sylvania Heads and Fogs-CA edgerider2002 Interior, Exterior, Electrical, & Misc. 10 03-23-2010 10:42 AM
HVAC lights, headlight switch light, 4wd lights not working.... Jwad00 General Technical & Electrical 1 09-05-2009 04:45 PM
Passenger side HID not working lownslow95 Exterior Semi-Tech 14 06-07-2009 10:22 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:35 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.