Key will not start Truck - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-30-2009
Member
Thread Starter
 
Join Date: Jul 2005
Location: Las Vegas, NV
Posts: 80
Key will not start Truck

Need some help guys......I was changing the power brake booster on a 94 xlt. I think perhaps I laid one of my wrenches across the battery and it shorted across the positive and negative terminals, That's what I'm thinking at least. I got the brake booster all changed and everything buttoned back up, bleed the brakes, went to start the truck to take it for a test. Foot on the brake, clutch down, turn the key and NOTHING. no sound nothing. hmmm, stereo working, lights working, turn key again and I can hear the fuel pump turn on and still NOTHING. I check all the fuses and relays in the box that is on the drivers side behind the battery and everything looks good. I'm thinking it's the starter relay, I take a screwdriver and jump the terminals on the starter relay and it fires right up like a champ. OK I must have a bad starter relay, I go to the parts store and grab a new relay, get it changed and still NOTHING. I don't know If I disturbed something when I was connecting the brake pedal back or what, not really sure at this point. Any help would be greatly appreciated.

Cheers
Reply With Quote
  #2  
Old 03-30-2009
b3kbruiser's Avatar
Member
 
Join Date: Nov 2006
Location: DFW Area, Tx
Posts: 713
Check your fuses, I think you have one specifiaclly for the ignition switch.
Reply With Quote
  #3  
Old 03-30-2009
Member
Thread Starter
 
Join Date: Jul 2005
Location: Las Vegas, NV
Posts: 80
If it's in the fuse box that's inside the engine bay I've checked and it's not blown. Is there another fuse I'm missing?
Reply With Quote
  #4  
Old 03-30-2009
chainfire's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2007
Location: Mission B.C.
Posts: 3,126
Drivers side, on the inside of the dash I believe
Reply With Quote
  #5  
Old 03-30-2009
b3kbruiser's Avatar
Member
 
Join Date: Nov 2006
Location: DFW Area, Tx
Posts: 713
No, there is another fuse box inside the cab. On my 94 Mazda it was right under the dash, to the left of the steering collumn. You will have to take a cover off it (no tools needed) and probably reference your owner's manual to see what it all is.
Reply With Quote
  #6  
Old 03-30-2009
chainfire's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2007
Location: Mission B.C.
Posts: 3,126
Ahh I didn't know they changed the placement. Mine is where I said.
Reply With Quote
  #7  
Old 03-30-2009
Member
Thread Starter
 
Join Date: Jul 2005
Location: Las Vegas, NV
Posts: 80
yeah, I've got into that fuse panel as well. I've pulled random fuses to see if any are blown and non have been thus far. I haven't been able to locate a diagram or key that say what number fuse is for what, Haynes manual not helpful at all. if anyone has a diagram\legend or knows what number fuse it may be I would extremely greateful
Reply With Quote
  #8  
Old 03-30-2009
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
haynes has all the fuses in it
Reply With Quote
  #9  
Old 03-30-2009
b3kbruiser's Avatar
Member
 
Join Date: Nov 2006
Location: DFW Area, Tx
Posts: 713
Do you have your owner's manual? It's in the matenence section.
Reply With Quote
  #10  
Old 03-30-2009
b3kbruiser's Avatar
Member
 
Join Date: Nov 2006
Location: DFW Area, Tx
Posts: 713
NOTE THAT THIS IS FROM A 1996!!! It may NOT be what you have, but if I recall correctly, 1994-1997 was pretty much the same. The 96 manual says it should be on the driver's side of the dash, on the side under a hatch, you'll have to open the door to get to it. However, on my Mazda, this panel was under the dash and had the blinker relays as well, but I don't remember if I have two cabin fuse panels, it IS possible and it IS possible you have more than one fuse for the ignition on the cabin fuse box(es).



Name:  2-2.jpg
Views: 94
Size:  34.9 KB

Name:  3-2.jpg
Views: 19
Size:  28.3 KB
Reply With Quote
  #11  
Old 03-31-2009
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
^^^ There was a major dash redesign for 1995MY and the fuse panels for 95-up are completely different from those in 94.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Since the problem happened immediately after the booster R&R, I would look in that general area first. There is a clutch pedal position switch on the clutch pedal pushrod which must complete the circuit from the red/light blue to the pink in order for the starter relay to be energized. It is easy to damage the switch or shift it off of the pushrod. Or maybe it is simply unplugged electrically.

If that's OK, then check to make sure that the red/light blue goes hot when the key is moved to the start position. It is powered from a 60A fuse (underhood box, front corner) via a yellow wire to the ignition switch.
Reply With Quote
  #12  
Old 03-31-2009
Member
Thread Starter
 
Join Date: Jul 2005
Location: Las Vegas, NV
Posts: 80
that's kinda where I was headed with the clutch pedal, although I was unable to find the switch assembly on the clutch pedal. Does anyone know where the switch assembly on the clutch pedal is located?
Reply With Quote
  #13  
Old 03-31-2009
Redrocket's Avatar
Member
iTrader: (6)
 
Join Date: Jan 2007
Location: Waynesville n.c
Posts: 1,993
it should be on the rod thats hooked on to the pedal it has a bounch of wires comeing out of it
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1999 Ranger loses all power when turning key to start Original T 2.9L & 3.0L V6 Tech 5 04-11-2014 02:29 AM
One key will start my truck.. the other does nothing? NewShockerGuy General Technical & Electrical 9 10-30-2011 11:17 AM
05 ranger wont start upon first turn of key?? fabioonachopper DOHC - 2.3L Duratec / Mazda L Engines 3 04-23-2010 09:20 AM
So I have this thump when i first turn the key on and dies before start btm757 4.0L OHV & SOHC V6 Tech 6 12-27-2009 10:07 AM
Truck cranks but wont start till i hold the gas down and turn the key Ranger_mayne 2.9L & 3.0L V6 Tech 15 10-25-2006 10:47 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:57 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.