Major electric problems. NEED HELP! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-04-2010
MothMan999's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Mar 2009
Location: Chantilly, VA
Posts: 858
Major electric problems. NEED HELP!

Ok so today after washing my truck i opened the door to smoke in the cab of my truck and an electrical burning smell. When i wired the dome light in my cap i wired it stupidly by just tapping into the fuse block inside the truck i just ran the wire back with no fuse or anything and the wire burned up for some reason. The problem is now my power windows, locks, windshield wipers, and fog lights do not work. I was dark out so i didn't mess with it much yet but i pulled the fuse for the windows and i used a test light and i don't have power at the fuse and the fuse is not blown. Not really sure where to go with this but if you have any info it would be great.
Reply With Quote
  #2  
Old 09-05-2010
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
looks like you cooked a part of the fuse block

jfyi: that was pretty stupid
Reply With Quote
  #3  
Old 09-05-2010
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
Check the fuses under the hood?
Reply With Quote
  #4  
Old 09-05-2010
MothMan999's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Mar 2009
Location: Chantilly, VA
Posts: 858
Quote:
Originally Posted by cheese_man View Post
looks like you cooked a part of the fuse block

jfyi: that was pretty stupid
Thats what i was thinking i might have done.

Quote:
Originally Posted by rangerboy101 View Post
Check the fuses under the hood?
fuses under the hood are fine.

Bump any one else.
Reply With Quote
  #5  
Old 09-05-2010
MothMan999's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Mar 2009
Location: Chantilly, VA
Posts: 858
Problem fixed it was a maxi fuse under the hood i didn't check last night.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need some major help with horn troubles, all help greatly appreciated!!! Cowboy713 General Technical & Electrical 12 02-29-2016 02:21 PM
Problems installing electric tailgate lock - need help Hillyard Interior Semi-Tech 2 09-07-2009 06:09 PM
major brake problems need HELP!!!!! Downey Drivetrain Tech 19 03-23-2009 01:53 PM
Major MPG Problems. cchsbuzz19 General Ford Ranger Discussion 26 11-30-2008 09:13 PM
Can I run two electric fans with my Bronco's stock electric system? winks General Technical & Electrical 10 10-10-2007 09:08 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:05 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.