Misfire - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-12-2013
Member
Thread Starter
 
Join Date: Jun 2013
Location: Lawrence ks
Posts: 4
Misfire

I have have an 04 ranger with the 4.0 v6. The hormonic balancer went out while my mother in law was driving it. She continued to drive it the 5 miles back to my house. So I replaced the balancer. Then it shows misfire cylinder 2&6 and a random misfire so I replaced the position sensor with a motorcraft sensor. Still threw the same codes so I changed the coil pack, plugs and plug wires. Still threw the codes again after 30 miles or so, don't know what to do next.
Reply With Quote
  #2  
Old 06-12-2013
02slammedranger's Avatar
Member
iTrader: (8)
 
Join Date: Jul 2009
Location: Dearborn, MI
Posts: 593
Have your mother in law buy you a new vehicle. FTW. Did you replace the cam shaft position sensor or the crank position sensor?
Reply With Quote
  #3  
Old 06-12-2013
Member
Thread Starter
 
Join Date: Jun 2013
Location: Lawrence ks
Posts: 4
Crank position sensor
Reply With Quote
  #4  
Old 06-12-2013
02slammedranger's Avatar
Member
iTrader: (8)
 
Join Date: Jul 2009
Location: Dearborn, MI
Posts: 593
Check the connector itself and look at the cam shaft position sensor that also could be bad.
Reply With Quote
  #5  
Old 06-12-2013
Member
Thread Starter
 
Join Date: Jun 2013
Location: Lawrence ks
Posts: 4
Now it is down to just a cylinder 6 miss fire wtf.
Reply With Quote
  #6  
Old 06-12-2013
02slammedranger's Avatar
Member
iTrader: (8)
 
Join Date: Jul 2009
Location: Dearborn, MI
Posts: 593
My 3.0 did the same thing and it ended up being that the spark plug on number 6 came loose but only misfired on the highway
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
cylinder 4 misfire skankinandy SOHC - 2.3L & 2.5L Lima Engines 20 10-15-2015 03:26 AM
Misfire 4,5,6 help. JDRead 2.9L & 3.0L V6 Tech 10 09-24-2008 02:10 AM
help misfire after i washed engine? vic 2.9L & 3.0L V6 Tech 3 08-13-2006 01:37 PM
Engine misfire???? phatspeed7x 4.0L OHV & SOHC V6 Tech 4 07-02-2006 09:08 AM
Misfire TBarCYa 4.0L OHV & SOHC V6 Tech 5 02-23-2005 11:14 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:35 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.