my first CEL... how do i fix it???? - Page 2 - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #26  
Old 01-30-2007
5speedin2.3's Avatar
Member
 
Join Date: May 2005
Location: Livonia, Mi
Posts: 12
goto autozone or something and get some "electronic cleaner".
any kind of contact cleaner i would assume.
they might even have something for cleaning MAF's.
i used starting fluid on mine so idk. or like bill said, carb cleaner.
Reply With Quote
  #27  
Old 01-30-2007
Member
 
Join Date: Mar 2006
Location: Loudon, NH
Posts: 77
NAPA sells a MAF cleaner. Don't know the advantages or difference, but they sell it.
Reply With Quote
  #28  
Old 02-11-2007
Strider0O0's Avatar
Member
Thread Starter
 
Join Date: Jul 2004
Location: Philadelphia, PA
Posts: 3,588
BUMP


well... it's been nearly a month, lol.

i finally have all of today to work on my truck.... this is honestly the first day in over a month that i have nothing planned, so i plan on spending the day on the truck.


anyways.... i'm about to head off to Pepboys to pick up oil and a filter.... i'll grab a can of MAF cleaner too.

this PCV valve..... where is it located?? where do i look to see if it's broken?? hopefully its like everyone elses and just came undone or something...

i'm crossing my fingers for a simple fix!!! wish me luck guys!!
Reply With Quote
  #29  
Old 02-11-2007
Strider0O0's Avatar
Member
Thread Starter
 
Join Date: Jul 2004
Location: Philadelphia, PA
Posts: 3,588
got the CEL fixed!!!!!!!!

once i got under my hood, i took off the 4.0 cover.. i was gonna take apart my intake, and clean it all out... then i noticed, almost right next to the throttle body, to the left of it, there was a little rubber 90* elbow that had a slit on the top of it... i pushed at it, to see if it was just a scratch, but it wasn't... it was a deep cut that went all the way through. so that was it. i used permatex, sealed it up... and bam.. problem solved!!!!

after that, i changed my oil... changed my sparkplugs and wires (finally), got my one headlight fixed (for some reason it wasn't working), and put on my skid plate which was laying in my garage since forever (got it from Travis from his first FX4).

it feels soooooo good to have a day to work on the truck and do nothing else... it's a load of my mind now.
Reply With Quote
  #30  
Old 02-12-2007
04 EDGE
Unregistered User
 
Posts: n/a
your fix will not last long.
Reply With Quote
  #31  
Old 02-12-2007
Strider0O0's Avatar
Member
Thread Starter
 
Join Date: Jul 2004
Location: Philadelphia, PA
Posts: 3,588
Quote:
Originally Posted by 04 EDGE
your fix will not last long.
why not? regardless.. if it does split open again... i'll just go buy a replacement.... im just happy i found where it was cracked more than anything
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
PCV Elbow - Fix for a very common CEL! WowMike2001 4.0L OHV & SOHC V6 Tech 36 05-19-2016 09:50 AM
First Ranger, First Post widriga Member Introductions 5 05-13-2015 01:27 PM
First Post, First Day, First Car. Sierra Invenio Member Introductions 8 05-12-2015 12:34 PM
Got my first CEL @ 74,000 Don't Say 2.9L & 3.0L V6 Tech 12 08-12-2009 06:33 PM
CEL and warranty problems 3LiterBeater General Technical & Electrical 23 10-14-2004 10:20 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:34 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.