Need help asap, put BL, truck wont start, work in 1h - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-06-2010
Seb_L's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2009
Location: Ottawa, Ontario
Posts: 1,071
Need help asap, put BL, truck wont start, work in 1h

Just put a BL on my truck, I'm sure I put all the grounds I took off back in, everything has been hooked up. What could have happend? It cranks, just wont start.

Please, anyone, even if you think it might not work I want to know
Reply With Quote
  #2  
Old 04-06-2010
Woods-Rider's Avatar
Member
iTrader: (2)
 
Join Date: Apr 2008
Location: Hillsboro, OR
Posts: 1,108
Maybe you pulled a fuel line off.
Reply With Quote
  #3  
Old 04-06-2010
Seb_L's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2009
Location: Ottawa, Ontario
Posts: 1,071
From where, engine? Where at the engine? Sorry to be blunt I'm just flippin right now
Reply With Quote
  #4  
Old 04-06-2010
Seb_L's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2009
Location: Ottawa, Ontario
Posts: 1,071
Another, gear was in park, truck was actually in neutral cause it started moving forward by itself. Could the cable be too loose?
Reply With Quote
  #5  
Old 04-06-2010
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
yes
Reply With Quote
  #6  
Old 04-06-2010
Toreador4x4's Avatar
Member
iTrader: (6)
 
Join Date: Apr 2007
Location: Livonia, MI
Posts: 3,958
check the inertia switch located behind the passenger kick panel
Reply With Quote
  #7  
Old 04-06-2010
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
I would put money on it being the inertia switch.
Reply With Quote
  #8  
Old 04-06-2010
Seb_L's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2009
Location: Ottawa, Ontario
Posts: 1,071
Little black cylinder with a red button!

You guys are ****ing awesome! Thank You! I would have never even thought of looking there

Thanks to everyone for the help, me love you long time
Reply With Quote
  #9  
Old 04-06-2010
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
lol go to work
Reply With Quote
  #10  
Old 04-06-2010
Toreador4x4's Avatar
Member
iTrader: (6)
 
Join Date: Apr 2007
Location: Livonia, MI
Posts: 3,958
damn im good LOL
Reply With Quote
  #11  
Old 04-06-2010
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
Quote:
Originally Posted by Toreador4x4 View Post
damn im good LOL
i can feel your ego down here
Reply With Quote
  #12  
Old 04-06-2010
Seb_L's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2009
Location: Ottawa, Ontario
Posts: 1,071
I was surprised as hell you actually got it lol A bunch of workers had been looking at me freak out for the past hour and when it started I was screaming and cussing, in a good way of course. They were laughing there asses off haha

Thanks again man
Reply With Quote
  #13  
Old 04-06-2010
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Justin ftw!
Reply With Quote
  #14  
Old 04-06-2010
Lazler's Avatar
Senior Member
iTrader: (18)
 
Join Date: Dec 2008
Location: Brantford, Ontario
Posts: 5,526
Quote:
Originally Posted by 04blackedge View Post
Justin ftw!
****ing right! haha
Reply With Quote
  #15  
Old 04-07-2010
annguyen1981's Avatar
Member
iTrader: (4)
 
Join Date: Apr 2009
Location: Chicopee, MA
Posts: 1,888
What's this inertia switch?
Reply With Quote
  #16  
Old 04-08-2010
Seb_L's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2009
Location: Ottawa, Ontario
Posts: 1,071
Fuel pump control switch
Reply With Quote
  #17  
Old 04-08-2010
c_root's Avatar
Member
 
Join Date: Jan 2010
Location: Campbell River
Posts: 34
That little b*tch cost me alot of money, couldnt figure it out, replaced fuel pump, ect, figured out it was a bad connection. Just gotta give it a jiggle and it starts right up.
Reply With Quote
  #18  
Old 05-01-2010
__Arod__'s Avatar
Member
 
Join Date: Apr 2010
Location: Central Florida
Posts: 287
I did the exact same thing. I wasted money for nothing. Ended up being that dang switch
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
need help truck wont start? Splash General Technical & Electrical 0 04-27-2010 09:50 PM
Help truck wont start whtedge05 4.0L OHV & SOHC V6 Tech 9 12-09-2008 05:19 PM
truck shut off, wont start, NEED HELP!! rideabikenick 2.9L & 3.0L V6 Tech 8 02-10-2008 07:34 PM
help!!! truck wont start Eazy-E General Ford Ranger Discussion 12 10-17-2005 09:22 PM
HELP...TRUCK wont start.... yumcheetos General Technical & Electrical 32 07-26-2005 06:15 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:07 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.