Need help w/ a Escort 2.0 spl - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-22-2008
tdaward's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: Whitesboro
Posts: 25
Need help w/ a Escort 2.0 spl

I've got a 97 escort 2.0 spl...the bolt on the timing belt tensioner broke. replaced it set timing (both arrows up) Now there is no fire. Replaced cam & crane sensors, also the coil pac. Is it possible to be 180 out? Checked all fuses Checked wires. Code reader had no codes found.
Reply With Quote
  #2  
Old 09-23-2008
05Edge-04GT's Avatar
Member
 
Join Date: Oct 2006
Location: Illinois
Posts: 399
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
SPL BOX HELP 1RNGER Audio & Video Tech 0 05-20-2012 10:17 AM
Need help w/ an Escort w/ no fire tdaward General Ford Ranger Discussion 16 09-30-2008 06:37 PM
sq? spl? advantEDGE Audio & Video Tech 13 07-02-2005 12:56 PM
SPL Metering Strider0O0 Audio & Video Tech 37 04-07-2005 03:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:58 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.