need motor help!!! 2.9L loss of power warm - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-06-2012
Member
Thread Starter
 
Join Date: Jan 2012
Location: fargo ND
Posts: 3
need motor help!!! 2.9L loss of power warm

ok so iv got a 1989 ford ranger with the 2.9L 5speed,
so it runs just fine untill it starts to get warmed up, then it just falls on its face and will only rev up to 3 grand. iv tryed everything i could think of, new cat, new tfi moduel, O2 sensor, fuel filter, cap and wires and new plugs, and nothing has seemed to make it any better. so if anyone knows what could be the problem let me know
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
87 ranger loses power when warm. bikrboi165 SOHC - 2.3L & 2.5L Lima Engines 0 12-03-2013 06:45 PM
1989 ranger 2.3l no power/poor milage (warm) fmlrommel SOHC - 2.3L & 2.5L Lima Engines 5 05-02-2013 08:03 PM
A/C works til motor is warm cotton66 General Technical & Electrical 0 07-14-2010 04:43 PM
Loss of Power, Sounds like Vacuum Leak herm59 4.0L OHV & SOHC V6 Tech 4 12-09-2008 02:48 PM
Xcal2. will it compensate for power loss from 32" tires? Roddy 4.0L OHV & SOHC V6 Tech 9 10-31-2008 08:13 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.