No horn, No turn signals, No cruise control, No 4x4 - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-08-2010
RangerXLT18's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: New York
Posts: 127
Icon4 No horn, No turn signals, No cruise control, No 4x4

i have hurd that the "clock spring" could be the possiable reason this is happening. i have looked into about the clock springs but curious if that will be the fix or if i will still be without turn signals, horn and so forth..i know the part isnt cheap and dont wanna dump the money if it wont be the fix. Has anyone had the same problem? or have any other ideas of what could be going wrong/ or advice? any forums or post/pics to fix the problem? Thanks!
Reply With Quote
  #2  
Old 09-08-2010
j99ranger4x4's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: Delaware, OH
Posts: 1,381
sounds like clockspring, and they arent really expensive, i wanna say under 100 at the dealer, its the only place u can get one or at a jy but cant buy from auto parts store. U can take your steering wheel off to gain access to it, pry up on the cover of the clockspring and look at the ribbons and see if their broken.
Reply With Quote
  #3  
Old 09-08-2010
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
is your airbag light on too?
Reply With Quote
  #4  
Old 09-08-2010
RangerXLT18's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: New York
Posts: 127
my airbag light is not on.
Reply With Quote
  #5  
Old 09-08-2010
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
oh that makes it a little harder to diag then...if your airbag light was on it would be a definite clockspring problem
Reply With Quote
  #6  
Old 09-08-2010
RangerXLT18's Avatar
Member
Thread Starter
 
Join Date: Feb 2009
Location: New York
Posts: 127
appreciate the input..i dont think i really have any other options then just to go with replacing the clockspring. i know the clockspring does deal with the horn and cruise control also but i think im having more problems. dam electrical ****. hopefuly itll be the fix.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
No Cruise control, No turn signals dash indicator lights on all the time. duster1947 General Technical & Electrical 3 12-01-2014 08:25 AM
ClockSpring replaced..still no horn..turn signals..etc. RangerXLT18 General Technical & Electrical 2 10-09-2010 09:21 AM
NO horn NO turn signals or cruise control???? RangerXLT18 General Technical & Electrical 6 04-08-2010 08:11 PM
Cruise Control/horn/Airbag problems bballdude03 General Technical & Electrical 11 02-19-2010 05:49 AM
Modding cruise control to a non cruise Ranger 2001fordranger General Technical & Electrical 1 07-29-2009 11:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:46 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.