Oil level guage problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-18-2008
Biz's Avatar
Biz Biz is offline
Member
Thread Starter
 
Join Date: Sep 2006
Location: los angeles,California
Posts: 2,120
Oil level guage problem

well the other day my oil guage kept acting up..goes up when i accelerate..and down when i let off...now its just sits on Low...i have oil ....anyone have any idea whats wrong?
Reply With Quote
  #2  
Old 07-18-2008
Roach2004's Avatar
RF Veteran
iTrader: (3)
 
Join Date: May 2005
Location: Houston, TX
Posts: 8,320
You talking about the gauge in the dash or what?
Reply With Quote
  #3  
Old 07-18-2008
Biz's Avatar
Biz Biz is offline
Member
Thread Starter
 
Join Date: Sep 2006
Location: los angeles,California
Posts: 2,120
yes..so liek right now..i turn on the truck and its mid way as normal..then after a minute it goes to low and then my check guage light comes on...then the level stays at Low
Reply With Quote
  #4  
Old 07-18-2008
99_NWRanger's Avatar
Member
 
Join Date: Apr 2008
Location: WA / Mountain Home, ID
Posts: 331
I'm not sure as to what might be causing this. First thing I would think is that its only getting enough pressure when you accelerate. On mine I'm having your problem except its when I start it it'll be at 0 then after about a mile or 2 will go up. I don't know if thats normal..
Reply With Quote
  #5  
Old 07-18-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Probably bad sender or gunk on it.
Reply With Quote
  #6  
Old 07-18-2008
Biz's Avatar
Biz Biz is offline
Member
Thread Starter
 
Join Date: Sep 2006
Location: los angeles,California
Posts: 2,120
so u think thats a bad thing?....if the sender unit is bad...will it mess up my engine?...
Reply With Quote
  #7  
Old 07-18-2008
99_NWRanger's Avatar
Member
 
Join Date: Apr 2008
Location: WA / Mountain Home, ID
Posts: 331
If the sender unit has gunk on it theres a spray you can use to clean it to see if the sender itself is bad.
Reply With Quote
  #8  
Old 07-18-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Quote:
Originally Posted by Biz View Post
so u think thats a bad thing?....if the sender unit is bad...will it mess up my engine?...
If the sending unit is bad then nothing will happen. Well you will lose your idiot light disguised as a gauge. Also your "check gauge" light will be on all the time.
Reply With Quote
  #9  
Old 07-18-2008
redranger_02's Avatar
Member
 
Join Date: Oct 2006
Location: Evansville, Indiana
Posts: 641
that is not an oil level gauge. that is an oil pressure gauge and should be checked out immediately or you risk damage to your motor!!
Reply With Quote
  #10  
Old 07-18-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Quote:
Originally Posted by redranger_02 View Post
that is not an oil level gauge. that is an oil pressure gauge and should be checked out immediately or you risk damage to your motor!!
No one ever said it was a oil level gauge. It could just be a bad sender. Get a gauge and hook it up the the test port, if there is one, and check your oil pressure. If there is none then your oil pump is bad or something is plugged. If you have pressure then the sending unit or gauge is bad.
Reply With Quote
  #11  
Old 07-18-2008
Biz's Avatar
Biz Biz is offline
Member
Thread Starter
 
Join Date: Sep 2006
Location: los angeles,California
Posts: 2,120
Quote:
Originally Posted by redranger_02 View Post
that is not an oil level gauge. that is an oil pressure gauge and should be checked out immediately or you risk damage to your motor!!
ahhh fack..it just happends to happen when i have no money lol..
Reply With Quote
  #12  
Old 07-18-2008
redranger_02's Avatar
Member
 
Join Date: Oct 2006
Location: Evansville, Indiana
Posts: 641
Quote:
Originally Posted by fddriver02 View Post
No one ever said it was a oil level gauge. It could just be a bad sender. Get a gauge and hook it up the the test port, if there is one, and check your oil pressure. If there is none then your oil pump is bad or something is plugged. If you have pressure then the sending unit or gauge is bad.
well the way he described it. it was like he thought it was an oil level gauge. just tryin to help him out
Reply With Quote
  #13  
Old 07-18-2008
Biz's Avatar
Biz Biz is offline
Member
Thread Starter
 
Join Date: Sep 2006
Location: los angeles,California
Posts: 2,120
thanks...i wouldnt even know where to begain to check....without having to take it to the damn mechanic
Reply With Quote
  #14  
Old 07-18-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Quote:
Originally Posted by redranger_02 View Post
well the way he described it. it was like he thought it was an oil level gauge. just tryin to help him out
Off topic but my friend thought his 1985 Nissan 300ZX had an oil level warning light like my 1993 RX7. So when the light came one he kept adding oil. I think he had 8 quarts in there and oil was shooting from the exhaust. Then the headgasket blew and the mechanic he took it to asked why he had so much oil. What a moron.
Reply With Quote
  #15  
Old 07-18-2008
Biz's Avatar
Biz Biz is offline
Member
Thread Starter
 
Join Date: Sep 2006
Location: los angeles,California
Posts: 2,120
haha...my oil seemed pretty low this morning..i added a quart just to get me down big bear mountain...thank god i made it home...after warming my car up for 1 minute the needle starts jumping...Im going to go to the autostore and buy a new sendiing unit...


Anyone have a pic or how to change a sending unit?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Oil Guage/Pressure Problem bucs57 2.9L & 3.0L V6 Tech 4 09-07-2010 09:23 AM
oil guage going nutz 2003stealthedge 2.9L & 3.0L V6 Tech 15 05-27-2008 10:44 AM
Oil pressure guage wiring Mykhael General Technical & Electrical 1 11-11-2007 10:05 AM
Possible Oil Pessure Guage Problem garymurch General Technical & Electrical 13 12-12-2006 04:28 PM
Oil Guage bludmon Drivetrain Tech 4 11-16-2006 07:37 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:09 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.