signal lights problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-18-2014
Member
Thread Starter
 
Join Date: Aug 2013
Location: bradenton fl
Posts: 5
Icon7 signal lights problem

I have a 95 ranger the signal lights are acting funny When the head lights are on and I turnthe signal on and step on the brake the back goes and the front flashes real fast when the headlights are off they work till I press on the brake then they go out Can anyone help me with this
Reply With Quote
  #2  
Old 10-18-2014
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Quote:
Originally Posted by rsantaniello View Post
I have a 95 ranger the signal lights are acting funny When the head lights are on and I turnthe signal on and step on the brake the back goes and the front flashes real fast when the headlights are off they work till I press on the brake then they go out Can anyone help me with this
based on your description its more than likely a bad ground. Id start by checking all the bulbs and their associated sockets first. If they check out ok, I'd look at the main ground G200 (ground for rear lighting). Unfortunately my sources do not reference the location for 1995. It might be somewhere on the rear frame member or inside vehicle floor on the left hand side (under carpet) next to where the wiring goes through the cab to the rear. If the grounds check out ok, then its more than likely a bad multifunction switch.

Last edited by Rev; 10-18-2014 at 01:51 PM.
Reply With Quote
  #3  
Old 10-18-2014
Scrambler82's Avatar
Old Guy Userů ltr
iTrader: (12)
 
Join Date: Jul 2009
Location: SoCal
Posts: 6,773
It's funny with grounds... lose the ground on one light and it can affect another.
If the front and rear light socket grounds are ok, check the Multifunction switch.
I had a 95 that the directionals would screw up, some of the time, I did find a ground wire bad but it did not help, what I found was the Multifunction switch in the steering column had one pin loose, fixed it and everything was ok again.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Reverse Signal & Parking Break Signal brainbox General Technical & Electrical 5 06-14-2017 08:24 AM
All warning lights on -- signal lights stopped working Rob91 General Technical & Electrical 1 02-04-2012 05:27 PM
turn signal/heater problem? smcasey88 General Technical & Electrical 3 02-24-2010 09:17 AM
Left turn signal problem Dieseltechy360 General Technical & Electrical 4 02-23-2010 06:16 PM
Turning Signal Problem TruckinChuck General Technical & Electrical 2 03-19-2009 10:17 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:40 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.