some one please tell me.... - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-26-2008
dirtybird819's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2008
Location: newark, oh
Posts: 448
some one please tell me....

some one please tell me what my windshield washers fluid, my dome light, my cruise control, my headlights and my horn have in common? they are effffed up!!

heres the story: i haven't drove my truck since Saturday, since its not my week to drive in the car pool, and when i got dropped off after work Tuesday i had to take the boy to biddy wrestling practice and on the way i needed to clean the windshield off and the damn thing wouldn't work, so i said the hell with it. after practice we got in the truck and when i started it wouldn't stop spraying, so i turned it off and started it back up and it was fine. i pulled out of the parking lot and my horn started up and wouldn't shut off, i again i turned the truck off then on and it keep blaring, so i pulled into the adjacent parking lot and popped the hood and covered my horn to try and quite it up and smothered for at least 2 min until it stopped. i got back in my truck and my dome light wont work.

well today i had to be at the masonic blue lodge to study for my EA degree, so the same scenario happened, got off work, ran inside then hopped in the truck. it was fine till i got down the road and the damn windshield washer started to spray. it only sprayed for about 20 seconds or so then stopped, i was just waiting for the horn, but it never came on.

after i was finished at the lodge, i waited for my fellow brotherens to leave before i got in my truck to started, i started it and everything seemed fine. until i turned on my head lights and the damn washer fluid started again. i noticed it didn't start until i turned on my head lights, so i turned them on and off over and over and over till i shut my truck off, then started it again and it was fine.

on the way home i noticed my cruise didn't work, my horn don't work, my washer fluid don't work, and my dome light don't work, and lord only knows what else doesn't work

right after i got the truck my radio wouldn't work in any other gear but park and neutral. i also tried to do the '04 fog light mod, but it never worked and they don't work at all after that

i was hoping somebody could tell me WTF is up. I'm so mad at this issue, I'm thinking off getting ride off the truck that i just got less than 6 months ago and still $11,000 on. is there any recalls on the '04 models that i don't know of? someone please help me out.

p.s. sorry for the long sentence and the long story, but i thought it was necessary to be though
Reply With Quote
  #2  
Old 11-26-2008
DisturbedESV's Avatar
Member
 
Join Date: Apr 2008
Location: Seattle, WA
Posts: 3,115
Nothing to do with your actual question... I know... but you're a mason?? I was a Jobie
Reply With Quote
  #3  
Old 11-27-2008
wydopnthrtl's Avatar
Member
iTrader: (2)
 
Join Date: Dec 2005
Location: SE, Mi
Posts: 2,342
LOL....LOL... ha ha ha..! Awsome!

Sorry there.. That's just funny. Maybe it's possessed?




When really odd things like this happen I'd look for corrosion at the main harness connectors. Or pinched or 1/2 cut wires.

Rich
Reply With Quote
  #4  
Old 11-27-2008
FireRanger's Avatar  
Join Date: May 2004
Location: CT
Posts: 0
You have a major wiring harness problem. You either have wires that are melted or a plug that is corroded and falling apart. I would discontinue driving the truck until you fix this unless you want it to catch on fire and burn to the ground.

Start lookking around under the dash and at the big plug in the firewall. Then follow it on the other side under the hood. Whatever the problem is will probably be obvious.
Reply With Quote
  #5  
Old 11-27-2008
sniper_101's Avatar
Member
 
Join Date: Jul 2005
Location: Sask, Canada
Posts: 1,902
I'm gonna bid on a ground, have had similar happen on my 92' K1500 and 88' Mustang. On the Chevy, just having the wiper board un-grounded caused idle surge, P-brake light flashing codes, wipers buzzing and shorting, A/C lights to flash and the alarm to randomly go nuts, including command starting itself.

I'd go searching for bad grounds at every chassis point, then move to testing each component with an issue. Also FireRanger could be very correct on the corroded plug or harness connections which, as said, could very well cause a fire. Don't let this go on, I'd disconnect your battery when the truck is sitting to be sure. Good Luck.

Last edited by sniper_101; 11-27-2008 at 05:36 PM.
Reply With Quote
  #6  
Old 11-27-2008
dirtybird819's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2008
Location: newark, oh
Posts: 448
Quote:
Originally Posted by DisturbedESV View Post
Nothing to do with your actual question... I know... but you're a mason?? I was a Jobie
yes i am a mason, im only an EA. im a member of Center Star lodge #11 out of the state of ohio, the oldest in licking county, 5th oldest in the state
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Some Camburg, some BTF, some Bilstein, some OEM yeatzee Snapshots 17 08-14-2012 05:17 PM
please tell me where my PCV is, Please (did search) uplandhunter General Technical & Electrical 16 02-07-2011 09:34 AM
emergency...please some one come get me unsuck...... bigandrw General Ford Ranger Discussion 51 08-30-2010 09:44 PM
Someone please tell me that this is a members truck CJGSAY General Ford Ranger Discussion 13 07-14-2008 08:11 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:14 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.