speakers dont work - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-28-2008
Member
Thread Starter
 
Join Date: Feb 2008
Location: Stocton, CA
Posts: 2
speakers dont work

i hook an aftermarket deck in my car awhile back, it was working fine, and now theres no sound coming form the speakers. deck still work just no sound could it be a blown fuse?
Reply With Quote
  #2  
Old 02-28-2008
03danger's Avatar
Member
 
Join Date: Feb 2008
Location: FTC, Colorado
Posts: 45
what year truck?
does it have a factory amp?
did you use a harness, or cut up the stock one?
Reply With Quote
  #3  
Old 02-28-2008
Member
Thread Starter
 
Join Date: Feb 2008
Location: Stocton, CA
Posts: 2
93 ranger xlt. didnt cut any wires
Reply With Quote
  #4  
Old 02-28-2008
03danger's Avatar
Member
 
Join Date: Feb 2008
Location: FTC, Colorado
Posts: 45
need more info,,, did it make any noises before going out, it could be the ground from the head unit.. thats the most common, next would be does your head unit have a internal amp, if so it maybe turned off if so it will shut off the speakers...
Reply With Quote
  #5  
Old 02-28-2008
03danger's Avatar
Member
 
Join Date: Feb 2008
Location: FTC, Colorado
Posts: 45
also what kind of head unit????
Reply With Quote
  #6  
Old 02-28-2008
01Blueedge's Avatar
Member
 
Join Date: Jun 2005
Location: Lexington SC
Posts: 535
i could be two speaker striped wires hitting because that what happened to my 87 ranger.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
99 ranger rear speakers dont work npauls General Technical & Electrical 1 08-07-2011 10:27 AM
speakers crackle mega bad. dont let me down forum rangerrunner11 Audio & Video Tech 5 07-13-2011 06:26 PM
dont like jap / korean cars, dont open this thread. Melt Snapshots 26 01-23-2009 09:06 AM
speakers speakers speakers doug435 Audio & Video Tech 5 01-30-2006 01:50 PM
why would my new alpine speakers sound worse than my stock speakers? james13f Audio & Video Tech 21 04-03-2005 06:01 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:56 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.