starter problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-24-2014
Member
Thread Starter
 
Join Date: Aug 2013
Location: bradenton fl
Posts: 5
Icon7 starter problem

I have a 95 ranger 4 cyl standerd 5 speed starter wont turn over just clicks once fuse ok new battery so I put new starter in still does the same thing just a click tried jump it at the solenoid on top of the new starter wouldn't do anything can anyone help
Reply With Quote
  #2  
Old 06-24-2014
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
the starter is seized , time for a replacement

if you jump the solenoid contacts and nothing happens , that is pretty much the clue
Reply With Quote
  #3  
Old 06-24-2014
Member
Thread Starter
 
Join Date: Aug 2013
Location: bradenton fl
Posts: 5
I just replaced it and it didn't start so I tried to jump the solenoid but it didn't do anything
Reply With Quote
  #4  
Old 06-25-2014
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
hmmm, by what you said , it sounds like you have a seized engine
Reply With Quote
  #5  
Old 06-25-2014
pearlkid9988's Avatar
Member
 
Join Date: Dec 2008
Location: Newnan Georgia
Posts: 828
Check the power line from the battery you may have a bad wire not carrying enough power but just because you bought a new starter doesn't mean it wasn't bad too id take it back and have them check it or replace it.
Reply With Quote
  #6  
Old 06-26-2014
Member
 
Join Date: Jun 2014
Location: gallipolis ohio
Posts: 74
sounds to me you need to check all your grounds when i swaped my truck from a 2.5 to a 2.3 i tryed to start it frist and it just click my ground was lose on the body of the truck or the fram i cant remember
Reply With Quote
  #7  
Old 06-27-2014
Member
Thread Starter
 
Join Date: Aug 2013
Location: bradenton fl
Posts: 5
its fixed just to let you know it was the he wire connected to the positive side of the battery When they installed the battery they put some grease on it witch blocked the connection took it off cleaned it real good and it startered right up
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
starter problem. Focklerx33 General Ford Ranger Discussion 1 01-05-2010 01:37 PM
Does this sound like a starter problem? richyrich General Technical & Electrical 6 09-29-2008 03:38 AM
Help Starter Problem! RageRanger General Technical & Electrical 2 02-13-2008 04:13 PM
Starter Problem realhighpockets General Technical & Electrical 10 12-27-2007 11:45 AM
starter problem Don.Hagen General Technical & Electrical 4 10-17-2007 10:32 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:47 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.