taylor spiro pro wires JUNK!!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-11-2016
cheese_man's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
taylor spiro pro wires JUNK!!!!

well about 6 months after i installed them , they are now leaking heavy EMI

so much so that my fuel economy dropped like a rock

so i am having magnecor custom make me a set of the 10.5 mm CN25 series ignition wires

anyone else suffering mileage issues your ignition wires are the problem

how can i tell , easy emi interferes with local radio broadcasts, especially when the engine idles .

you can hear low level whining , if your hearing is still good
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Plugs/Wires (wires bad) ROSCO 4.0L OHV & SOHC V6 Tech 8 11-02-2011 12:01 PM
For Sale: (4) 33x12.50R16 Pro Comp Xterrain's on polished 16x8 Pro Comp 1079's - OR 03whtEDGE Suspension, Tires, & Wheels 2 07-27-2010 07:32 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:47 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.