Truck nearly shuts off when I shift from Drive to Park - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-29-2011
Member
Thread Starter
 
Join Date: Jun 2011
Location: Stuart, FL
Posts: 14
Truck nearly shuts off when I shift from Drive to Park

I have a 2001 Ranger Edge and just a couple days ago I started having this issue where my truck nearly shuts off whenever I shift from Drive to Park. I also noticed that whenever I shift into Drive the trucks revs up to nearly 1k. I was wondering if anyone would have any idea as to what the problem could be?

I should also add that the truck has just over 165k miles on it and I just got a new battery installed because my last one died. I have been running a speaker system on my truck since day 1 and I have never needed to get a new alternator and I noticed this morning that when I had the volume turned up, my battery meter on the dash was rising and dropping like crazy which I have never noticed before....would the alternator have anything to do with both of these problems?

I have never had the serpentine belt replaced in the ten years I've owned it, could that be a cause?

Sorry for so many questions, but I would rather get some info on this forum than take a mechanics advice because a lot of the time they are just trying to get more money out of you.

Last edited by chad2584; 06-29-2011 at 11:58 AM.
Reply With Quote
  #2  
Old 06-29-2011
redbaron's Avatar
Member
 
Join Date: Apr 2011
Location: London, ON
Posts: 69
I had the same issue not long ago. There are quite a few threads about it. General consensus seems to be that it's the Idle Air Control Valve (IAC) that causes that issue. I was able to clean mine and it's been running fine since.

https://www.ranger-forums.com/general-technical-electrical-18/stalls-when-shifting-park-121764/
Reply With Quote
  #3  
Old 06-29-2011
Member
Thread Starter
 
Join Date: Jun 2011
Location: Stuart, FL
Posts: 14
Thanks for the advice, I will try to clean the IAC before I do anything else. One thing though, could you tell me where the IAC is? I think I know where it is but it is not in the same place as the image shown in the link you posted. Are they usually in the same place on every Ranger?
Reply With Quote
  #4  
Old 06-29-2011
Member
Thread Starter
 
Join Date: Jun 2011
Location: Stuart, FL
Posts: 14
Trying to post a pic of the IAC but am not sure how to do it.....
Reply With Quote
  #5  
Old 06-29-2011
Member
Thread Starter
 
Join Date: Jun 2011
Location: Stuart, FL
Posts: 14
Truck nearly shuts off when I shift from Drive to Park-2011-06-29_14-08-07_464.jpg

Ok, figured out how to attach files, is that my IAC?

Last edited by chad2584; 06-29-2011 at 01:10 PM.
Reply With Quote
  #6  
Old 06-29-2011
Member
Thread Starter
 
Join Date: Jun 2011
Location: Stuart, FL
Posts: 14
Just went to Advance Auto Parts and got some CRC Intake Cleaner and I noticed something when I shifted the truck into Park......the truck didn't idle rough like it has been. I had the A/C on at the time, so I turned the air conditioner off and the truck nearly shut off again after shifting from Drive to Park.

Why would this problem only occur when I have the air conditioner turned off?
Reply With Quote
  #7  
Old 06-29-2011
Member
Thread Starter
 
Join Date: Jun 2011
Location: Stuart, FL
Posts: 14
Well I cleaned the IAC and I am still having the same problem. Should I be seeing results immediately if the reason for the problem is because the IAC is dirty or does that mean that there is another problem?

Again, I noticed that the problem does not occur when the air conditioner is turned on....only when it is turned off.

What should I do now?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
96 Ranger shuts off, No one knows why. Jason530 General Technical & Electrical 0 05-19-2013 03:51 AM
Help! truck wont go into park (keys stuck) shift linkage? TexasRanger General Ford Ranger Discussion 13 05-15-2013 08:16 PM
Shuts off after warmed up muddmn08 2.9L & 3.0L V6 Tech 2 12-12-2010 05:46 PM
Truck shuts off in reverse, rough idle in Drive. Riddla 4.0L OHV & SOHC V6 Tech 5 12-06-2010 08:51 PM
Shuts off Fordranger1998 SOHC - 2.3L & 2.5L Lima Engines 6 10-02-2007 11:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:46 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.